Pixhawk - servos not working

Hi guys,

I have finally received back my defective Pixhawk (issues loading firmware) and have loaded the firmware for Traditional Helicopters. All is good, I have calibrated my radio, the accel, the compass etc and can arm the system.

The issue I have is that the servos don’t work.

I have connected a separate 5V DC supply to channel 7 of the Pixhawk main outputs (from a separate BEC unit) to allow power to the servo rail (as per the wiki). I connect the servos to main outputs 1-4 but have not yet been able to get them to move. They don’t even “lock” into position when connected.

Is there any way I can test the servos to find out if (again) I have another faulty unit.



Hi Brad,
You do have the safety button connected and have pressed it to arm the Pixhawk, this is in addition to arming by holding down the rc throttle stick down and right. :smiley:

Also, how are you powering the servo output bus?

Hi guys,

Thanks for the responses.

I do have the safety button connected. In my case (not sure why), the LED on the safety switch is solid (not blinking). I arm my system by using the throttle to zero and rudder full right for 5seconds. The green LED on the Pixhawk stops blinking and goes solid and I get a long audible tone. The Mission Planner software states that the system is armed.

In terms of the servo bus power, I use a BEC regulated output (5.1v) to power one of the unused channels. I have measured 5.1v across all the + and - pins on the output rail.

I suspect I have (another) faulty unit. I found some terminal tests on another website that I can use to send a PWM signal to each servo. I will give this a go and unless I get any other tips I can use, I think I will return it again.

Any other ideas however are welcome!

Cheers, Brad.

Hi Brad,
Just checked on my Pixhawk, when you power up the light in the safety switch should pulse, like a heartbeat. It will continue to blink like this (even after the long tone has sounded) until you press it in and the light changes to solid to confirm that the system is now powered up, and your servos should now operate.
If the light in the safety switch is solid and does’t blink then maybe there is something wrong with the code you have loaded.
Maybe try loading up the arduplane code and see if the safety switch works normally.
Cheers, Martin :slight_smile:

Which firmware are you using?

I am trying to get this to work on a traditional heli. I have tried Ardu Plane and the same response re the safety LED is observed.

I am going to connect to the serial port and use NSH to diagnose the pwm outputs to see if they are indeed armed. If they are, it is a faulty unit. If not, there must be a software issue.

Interestingly, I run the software with the arming checks disabled. If I enable them, I get an error when trying to arm “Arm:safety switch”. However, pressing the safety switch doesn’t actually do anything? I have checked the switch and it works fine (using a meter).

Well, I have tried to follow the instructions here: dev.ardupilot.com/wiki/interfaci … g-the-nsh/ for creating a serial cable and interfacing to the Serial 4/5 port.

This port is not working and the device boots with an error if the cable is left plugged in (with USB FTDI adaptor powered - 3.3V).

I managed to get into nsh via the USB port (test\shell command). I sent outputs to the different channels using the “pwm test” command (instructions here: pixhawk.org/firmware/apps/pwm). Needless to say I have no response.

I have tried different firmware, no difference.

I suspect I have a board fault that is causing issues with my arming switch, my serial port and my I/O connectors.

I can’t imagine that this device is that difficult to set up to a basic level. I have spent countless hours troubleshooting and going in circles (this is now my second unit), reading the internet forums etc. Either I am just unlucky or these devices are very poorly made and unreliable. I have been working as an automation engineer in oil and gas for 15 years and have never had this much trouble with a device I needed to program.

Given that there are no 3DR guys on the forum to help, I will send this back.

Hi careyba,

Please contact us at help@3drobotics.com, provide order number and also your previous RMA number.

I’m sorry for all the trouble.

I have sent an email to the above address

Same thing happened to me… what worked for me to calibrate the ESC first… ie throttle max, energize the pixhawk and throttle down and restart.