Pixhawk says its armed but motor's wont spin

So I have flown this copter 20 times, didnt change anything apart from the SD card to try and avoid it failing to boot up for SD card problems. So I fly it last week, bring it in to change batteries, go to take off again and the motors won’t spin up on arm. I bring it in, re-calibrate the ESC’s because that fixed it once before.

Re-install the firmware and start again, nothing. Same thing every time with the exception that it sometimes will arm the first time I try on new firmware, but not again.

Tried new transmitter, nothing.

Tried new ESCs and motors. Nothing

3DR tech support keeps telling me that it is a setting problem, but please watch this video to see that I follow the correct procedure for binding the radio and calibrating the radio and ESC’s and it will “arm” but the motors will not spin for any throttle position.

I am 99% sure that the board is bad, but I would be more happy if someone could tell me what I did wrong.

Thanks for the help


Robert just posted the video to all the devs. I think somehow you are going back into calibrate mode when you arm. Might be something to do with the separate supply to the ESCs.

After reviewing this and other sources I have come to the following:

  1. If you plug in the Pixhawk seperate from the ESC’s you either have to plug them in very close to each other, plug the ESCs in first, or wait for the ESCs/motors to start beeping which is about 30s after you plug them in then it will arm every time.

  2. Maybe my flight control battery was bad, even though every time I checked the output it was 5.2v I swapped it and I am having better luck.

  3. I was having these sounds kind of alternate before this is why I was confused about the firmware being correct youtube.com/watch?v=9dgOsGCe4e0 The documentation says that the sounds should be the opposite, where the 3 tones is a correct update. not the musical tone.