Servers by jDrones

Pixhawk Refuses to Arm When QGroundControl is Connected


(Christopher Bonner) #1

I recently finished a quadcopter build using a Pixhawk 2.1 Cube, 3DR telemetry radios, Spektrum DXe TX, and using QGC. The build flies just fine and I’ve successfully had the aircraft working in several modes (Alt. hold, Pos. Hold, Auto, RTL) but today I experienced a new issue:

For today’s flight I finally got the live telemetry working with my laptop using QGroundControl. I was able to get it to run an auto mission (auto takeoff - waypoints - then auto landing) but struggled to get it to operate in any of the manual modes. When connected to the ground control software, the copter refused to arm conventionally (throttle down & to the right).

  • GPS lock was achieved
  • Radio transmitter was connected and working (I could toggle flight modes audibly)
  • I could launch the quad in QGroundControl using the GUI and take over steering once in the air
  • LED indicators on the Here GNSS puck were flashing green
  • No pre-arm warnings/errors

I’m probably overlooking some obvious setting or technique. Any help is appreciated.


(DonLakeFlyer) #2

I don’t see how a ground station connection would make any difference. Are you sure that is the case? Try arming with transmitter with no GCS connected. To determine why it refused to arm you are going to need to ask the firmwraee folks.