Pixhawk randomly spins yaw and motors dip speeds after 3 min

I am not sure if both of these things should be in one topic, but I’m putting them together because they are possibly related. I put a Pixhawk running ArduCopter 3.3 on my homebuild H quad frame. I set it up through MP with no problem, other than a small issue with the power module not measuring the battery correctly. The quad is powered by a tether supplying 11.3V @ 25 amps but it only pulls 5A nominal. I tried flying it today in stabilize and encountered two issues:

  1. The yaw randomly will move left or right sometimes as much as 90 degrees. It is possible that the tether is moving it, but could someone please check that it’s not the software? I tried to trim it out, but it changes direction often. The only occurs some of the time though, so for 70% of the time it flies normally.
  2. At about 3:45 into the flight, my front right motor dipped in speed and the quad banked to about 45 degrees in both roll and pitch. I did a touch and go then brought it back into the air. Shortly thereafter, the front right motor dipped again, and this time it flipped over. An interesting note: The Pixhawk did not register the crash and I had to manually disarm. Is this a hardware problem or a software problem?

Diagnostic info from the quad:
From the message tab in MP:

PX4v2 00550030 31345104 32363834 Frame: QUAD PX4: 34e1d543 NuttX: 7c5ef883 APM:Copter V3.3.3 (acf2e10c)

The bin file from the flight is too large to attach so here is the dropbox link:
dropbox.com/s/9feuikcl6qhpa … 6.bin?dl=0