Pixhawk, PX4Flow, and FW 3.3.x not working?

I’m helping a local university with a drone project. They’re using 3DR
Pixhawk FC along with the PX4Flow Optical Flow Sensor. The problem is we
can’t seem to get them to work.

I’ve installed a Pixhawk and PX4Flow to a Y6 frame. I installed the latest
Pixhawk firmware (3.3.x) which I understand is supposed to support Optical
Flow. I’ve followed the connection instructions linked in the post above,
set the EKF GPS type to 3 (to disgregard the GPS and use Optical Flow) and
enabled Optical Flow in the ‘optional hardware’. I’ve disabled ALL and GPS
in the Pre-Arm checks. I set my flight mode to Loiter. The FC won’t arm
though. I keep getting a ‘No 3D fix’ error. I can arm and take off in a
non-GPS mode, but when I switch to Loiter in flight I can hear the buzzer
going off (indicating an error) and there is no attempt to hold position.

So, what am I doing wrong? I even tried uplugging the GPS from the Pixhawk
with the same error when trying to arm in Loiter mode.

If I leave the GPS active (EKF GPS Type=0) and enable the Optical Flow
sensor do they work in tandem with each other? I’m kinda lost here and I’ve
yet to find any documentation/instructions on Pixhawk and PX4Flow that
seems to work. Thanks for any help…

I assume the Wiki instructions that you followed where here: http://copter.ardupilot.com/wiki/common-px4flow-overview/

Yes,thank you, those are the wiki steps I’m following. When I set the EKF as described:

  1. Set the EKF_GPS_TYPE parameter to 3 make the EKF ignore GPS and use optical flow data.
  2. Ensure you have LOITER mode and STABILIZE mode available on you transmitter.
  3. Take-off in loiter and bring the copter to about 1m height initially.
    Well, it won’t arm in Loiter because of ‘No 3D lock’. If I arm in Stabilize mode, then switch over to Loiter the beeper starts buzzing and the ground station starts warning ‘No 3D lock’. I can take off, but there is no attempt at position hold.

I have had the same problem, but some things I noticed when setting up. The PX4 Flow needs to be mounted in a different orientation or the settings changed (-9000 if I remember correctly). I charted the logs per the instructions, and everything looks good. I have Armed in Stabilized then switched to Loiter for takeoff. Everything seems to go OK at first, then the quad I am using to test with makes sudden jerky motions laterally. At one point it even took off on me and I had to put it back in Stabilize to regain control. I have a LiDar unit to use in conjunction, but want to confirm the PX4 flow works before strapping several hundred dollars to the quad.