Pixhawk problem


i have just received my new pixhawk autopilot but i have many problem during calibration process.

In detail i have installed the last ArduPlane firmware (v3.2.0) successfully but every time i try to calibrate the accelerometer (initial setup/Mandatory Hardware/Accel Calibration) i got always the “calibration failed” message. I have done that procedure dozens of times and in different way but nothing is changed.

The autopilot isn’t still placed in the airplane and during the calibration i hold it in position on a my desk, so absolutely no vibrations could interfere in the calibration.

I’have tried to install also qgroundcontrol firmware to check the health status of the board and, with may difficulties, i finally could get a good acc calibration. I have also tried to use directly the USB cable or using lipo battery to power it and radio link to pc connection in order to avoid usb connection fail but i got always the same message.

An other problem i have found is about terminal connection: every time i try to connect trough terminal i got only random char mixed at some meaningful message. i thought that was a baudrate problem but also using others baud the problem persists.

I have no more ideas, i’m just thinking my pixhawk is broken.

Someone of you have different ideas.

thank you

The CLI is disabled in this version.

I suggest that you read the ArduPlane Wiki which should provide answers to most of your issues: http://plane.ardupilot.com/wiki/table-of-contents/

thank you for your quick answer.

I have already followed the arduplane wiki to setup my pixhawk from firmware flashing to configuration. I have done all the steps again but however i fail accelerometer calibration.

Reading the guide i found that it is not a big deal if i don’t chose to use Kalman Filter to attitude estimation but i would like to understand if the problem is in the board (in that case i will try RMA) or inside me :smiley: .

anyone has any suggestion or test to do?

thank you

About terminal connection: I had the same problem when I upgraded to the latest new FW on my apm2., I have uploaded back to a prev. fw, and the problem was gone.
Maybe its a bug, dont know.

what is actual problem for pixhawk V3.2 can connect to terminal? and got a funny character like photo above.