Pixhawk not receiving PWM signal through SBUS(firmware = Copter 4.1.0 official)

Using the DSO I tried to figure out whether my pixhawk is receiving the PWM signal or not…
Comes out that the DSO wasn’t showing any PWM signal as required but was showing a straight line.
At the same time the Mission Planner was connected with my pixhawk and in the Data–>status–> ch3…It was showing that PWM signal is getting transmitted so no issues in transmitting the signal but it ain’t getting received.
All the connections were properly done and were verified.
The major problem was that my ESCs are not getting calibrated. For that I thought to check if my pixhawk is receiving the signal or not…Result is it is not receiving.

If you see RC channels moving in the MissionPlanner radio calibration screen, then you are getting RC in alright.
Assuming you’ve set the correct frame type/class and done the radio calibration sequence in that screen then you can do the ESC calibration like this, the semi-automatic method:

Then you would use the MissionPlanner motor test to check all motors spin up equally and are in the correct layout. Arming and trying to throttle up “on the bench” wont give predictable or expected results.

Let us know how you go and if you need more help.

After connecting to Mission Planner do you see this in the Messages screen?

Seems to be a rash of these head slappers lately :slight_smile:

Thanks a lot ! .It worked out :+1: