Servers by jDrones

Pixhawk not booting normally and Not powered from battery

Hi everybody.
Several months building a large quad with pixhawk px4 fmuv2 installed, and long range video transmission, with a gimbal, and powered by a large 22volts 12000mah battery. The whole weight is 4kgs, and the quad flew for continuous 35 minutes. I was very happy about the long flight time and its good stability. Until last week, and just the second flight when I was trying video recording above a lake, and after 5 minutes flight, the quad began to wobble crazily, and I couldn’t control it before it was falling into the lake and sunk. After five hours, I was able to extract it from 3 meters under water ,using a water bike and following last GPS position in QgroundControl.
After reviewing the log, and connections, I concluded that the cause might be a disconnected wire from the power board which touched the board and caused it to burn, although the ESCs were directly connected to the battery and the pixhawk directly to the power module.
I disassembled all the parts,clean, brush,dry… and I was happy I could recover all of them except for the pixhawk.
After first connect to Pc via usb port, it was powered normally, all leds and main light were functionning OK. But I couldn’t power it from battery. Another thing was that I could install the px4 firmware on it but not the arducopter and the main led light never lit. And after a stupid try of installing px4io bootloader from sd card, the pixhawk was no longer seen from MP or Qgroundcontrol, I tried the python loader , it gave a message “waiting for the bootloader” although I tried to hold switch while powering the pixhawk.

Note: the leds status when connected to pc in normal mode:

IO POWER AND FMU POWER:ON
IO B/E: ON
IO Act: blinking

When in boot mode
IO POWER AND FMU POWER:ON
IO B/E:blinking
IO Act: OFF

Pictures Before and after crash and log file are attached**
Uploading: 20200212_215731.jpg… Uploading: 20200317_154851.jpg… Uploading: 20200317_175513.jpg… Uploading: 20200317_175517.jpg… https://drive.google.com/open?id=1lMIJXHXnNArYOJhicrXHQeZLS-_y1VWJ
Any help to recover my pixhawk back and also resolving powering problem from battery will be really appreciated.
Thx in advance

If your pixhawk spent three hours underwater, all you can do is to throw it into the bin and add a new one. Beside many things, barometer is not waterproof, and pixhawk boards are not conformal coated.

Although it seems you have changed some of the ATC_ values your PID’s are stock.
You can see in the log that when you let off full forward pitch it went into an oscillation.
This triggered an EKF Failsafe and it went into land mode.
If you had changed into Stabilise at this stage you may have saved it.

You are not logging current but the voltage gives little indications of a short.
Did you Autotune this copter?
I probably don’t need to mention the inadvisability of doing your second only flight over a lake.

Yes, I remember that this happened just after a full forward pitch.
and unfortunately the quad was not autotuned :(, I learnt to do it the next time.
Thank you guys.

Oops

It will help you :slightly_smiling_face:

https://ardupilot.org/copter/docs/common-tuning.html

Servers by jDrones