Pixhawk no TX stick control during flight with 360 yaw

This is a new build with successful flights all week, the last, I had total lack of stick control in Loiter mode. Did have flight mode control. On takeoff it started a 360 degree Yaw and was about 15/20 feet, I flipped it into RTL, it when up a good 60 feet, passing its 45 foot parameter height. The barometer came to mind, might be off because it was windy. I tried RTL twice but it keep going higher and I discontinue that process. As it continue to Yaw, I applied Yaw in the opposite direction to counteract the rotation to no effect. Tried pitching forward in Loiter mode but that had little effect plus that would have only moved it further away from us. AltHold work but it drifted with no stick control. When we did get it into Stabilize mode (had to update that mode through telemetry as we just removed it earlier) pitching forward had little effect and it started to drop down. As it was going down it started to tumble, I flipped back into Loiter and that stopped the tumble. At this point I flipped it back to Stabilize, it made its way down through some 100 pine trees in a wooded area.

Here are two sets of log files as telemetry was disconnected and connected during the flight ( believe)


Any help or opinions would be appreciated, Thank you

Any thoughts on why there was no response to stick control?