Pixhawk Lost Connection

I am not sure what is going on but last night I connected my Pixhawk to APM 2.0.10,

“Mode changed to stabalized for sys 1”

then a few seconds later I get

“Link lost to system 1”

If I keep at it, it will eventually connect. I have tried to uninstall and reinstall 2.0.10.

I do not see the same thing with APM 2.6. I was able to reproduce it with RTFHawk, although not my main board I had it on my desk and it does the same exact thing so I grabbed the logs (attached).

We are re-wrting the serial port handling for the next release 2.0.11. With the update of OSX 10.9.3 it seems to have regressed on previous stability gains. We hope the new fix will solve this problem. 2.0.11 should be out early next week. I’ll post a link to a daily build when we have one you can test.

Hi, I am on OSX 10.9.4 and have APM 2.0.14 and facing the same issue. What is the work around? Currently, I reload firmware to vehicle and that seems to do the trick.

i am having the same issue. it is FRUSTRATING as hell to try to tweak anything. it randomly loses its link and i have to make no less than 5 disconnects and reconnects before it loads all of the parameters. then…IF i am lucky enough to make some changes before it loses its link again i have maybe 30-40 seconds at best.

two months since the last request for an answer and no replies?

APM board

Having similar issues. But I am running Yosemite now so to be expected I guess. Trying to download logs is a painful procedure. numerous disconnects and soooooooo slow. Mavlink even worse!

Whats the recommendation? Reinstall Mavericks? I do have an old Mac running Snow leapord…maybe I’ll give that ago. :stuck_out_tongue:

Hey, but seriously. Thank you to all the developers out there. This is an amazing system and all of us non-developers (I wouldn’t know a line of code if it came up to me and slapped me with a wet fish) are grateful for your hard work.


What version are you running? Try updating the beta by selecting the option in APM Planner 2.0 Configure view under the Config/Tuning option.

It has fixes for log downloading

Yep tried using both versions. Mavlink is basically unusable in both versions for larger logs. It continually loses “link” for 10 second and reconnects for another 1.

Using USB things are somewhat better, but it still, regularly, disconnects and reconnects. I don’t think its anything to do with my usb lead or even the telemetry link as this only happens when I try to download the log.
I’m assuming its not pixhawk either, but being a bit of a noob I’m not sure how to exclude it.

Any help Much Appreciated.


If it’s the audio announcement, then it’s not loosing the link for downloading, just that the log downloads it slowing the heatbeat message that says the link is alive. You can ignore this when downloading logs. I’ll add a fix to ignore sending that when downloading logs.

For speed, you can always eject the sd card if you can access it

OK Thanks.

Again, sorry to be a noob. So how long should It take an average file 2-3 MB file to download? And do I have unreasonable expectations? I was figuring in seconds rather than minutes! and thats for USB. The Mavlink download is more of a “start downloading 1 file, go away and make dinner, and when Ive finished with desert might be finished…if I’m lucky” type of thing. Again what is realistic it terms of time?

It’s about 20 seconds on USB for me for 2MBytes. Can you post a log from ~/apmplanner2/log.txt of your download?


Reinstalled Beta version. USB Seems to be much quicker now. Can’t attach the text file. Would you like the tlog or data flash log anyway?

Just need to zip it first and then you can attach it.

Even if slow. Does it download successfully?

Sorry Man. Thought I’d replied to this. Reinstalled APM Planner 2.0. usb seems up to speed. Mavlink still terrible. this forum won’t allow me to attach that text file you requested. Would my logs be of any use?

[quote=“billbonney”]Just need to zip it first and then you can attach it.

Even if slow. Does it download successfully?[/quote]

You can attached a text file, ie. ~/apmplanner2/log.txt if you compress it first using WinZip or some other compression utility. I need the APM planner 2.0 logs to glean any more information. Thx