Pixhawk Internal Compass Calibration

OK. That should use the Pixhawk 1 build. Try downloading the arducopter.apj file from the firmware server here: https://firmware.ardupilot.org/Copter/stable/Pixhawk1/ (right click > save as)

Then install using the “install custom firmware” function of Mission Planner. This will ensure that the firmware being installed is definitely the right one.

1 Like

For Radiolink PixHawk Advanced Autopilot I use FMUv3 as it has not the 1MB limitation!

In Copter 4+, the build is no longer called FMUv3. It is now called Pixhawk1. https://firmware.ardupilot.org/Copter/stable/

I still load FMUv3 firmware in all my 2MB Pixhawks.
Shouldn’t Pixhawk1 be used for 1MB Pixhawks ?

Not necessarily. There is specific firmware for those. 1-1M

There is no such thing as FMUv2 or FMUv3 anymore in ArduPilot as of Copter 4. It was a horribly misused and misunderstood build target name, so things were changed to make it much more clear what build targets are for what. This is actually a great example of that problem!

There is now a build target called Pixhawk1 (replaced FMUv3), which is for the Pixhawks and clones that don’t have the 1MB flash limit. There is also a Pixhawk1-1M build (replaced FMUv2), that as the name implies, is for the 1MB flash limit boards.

If you have a Pixhawk 1 or the many clones, you should use the Pixhawk1 build. If you have one of those 1MB flash limited early pixhawks/clones, then you should use the -1M build.


But there is still Fmuv3 Build: https://firmware.ardupilot.org/Copter/stable/fmuv3/

Take a look at the hwdef file for Pixhawk1.
2 # for pixhawk1, based on fmuv3
4 include …/fmuv3/hwdef.dat

I have pixhawk 2.4.8 and mission Planer by default copied version 4.0 for fmuv2. Despite the driver has 2mb I did not receive some parameters, e.g. the possibility of connecting an external parameter. after installing pixhawk 1 firmware everything was ok. I went further and manually uploaded the firmware version for Fmuv3 and everything is ok. Hex with two Gps, two barometers flying well …

if you have pixhawk 2.4.8 try upgrading to copter 4.0 fmuv3. I use both pixhawk and external compass in gps module and everything works ok.

Matt, I know the history of FMUv3 - the first Cube - and Philip at CubePilot fuming at the chinese clones using v3 STM32F4s creating confusion.
But someone has to go public and broadcast the changes. ;(

Yes, it’s probably a step too far to say that, “there’s no such thing as fmuv2 and fmuv3”. Instead it’s more that we recommend users pick the firmware that is a better fit for their board (i.e. Pixhawk1, CubeBlack, etc). It’s difficult for us to remove the fmuv2 and fmuv3 from the servers because many users are still using them… so it will be a (slow-ish) transition to the new, more specific firmwares.

Up until recently it’s been difficult for most users to actually chose which firmware goes on their board. It’s fairly easy to chose the version (stable, beta, older version etc) but not whether you want fmuv2 vs fmuv3 vs Pixhawk, ChibiOS, NuttX, etc, etc so we’ve been working with MichaelOborne to make a new firmware installation page on MP that lists all the possible compatible versions for the board so the user can choose.

OK, nevermind. I just need to up my caffeine intake. I didn’t notice the two different sort orders on the firmware server and stopped looking for FMUv3 when it wasn’t with the other F’s at the top.

I think Pixhawk1 would be the appropriate build target for you since that’s a pixhawk clone.The build target includes all hardware supported by FMUv3 anyway.

Off to hook up my caffeine IV before replying further…

1 Like

im having the same problem. trying to config and no gps/compass is being recognized. everything is brand new from radiolink. this is for my s550 hexacoptor. now i cant figure out how to get the right firmware on the pixhawk. when i plug it in, it chimes and the buzzer makes the positive buz at the end. i go to connect and seconds after i push connect, i get connection failed “there was an unexpected error” ill attatch 2 screen shots.

That was your 1st mistake. Which Radiolink Flight Controller? On the port pulldown, where it says AUTO, see if there is another COM port shown and select that manually.

i ended up buying a new gps unit. mine didnt seem to even light up. but i still am having trouble. it does detect the board. on the pull down it will usually be com port 5. i have tried to load several firmwares on it tonight thinking “thats the one” and nope, still getting no gps recognition period and this gps is displaying a blue light.

Hello, I have exactly the same problem. Pixhawk 2.4.8 Radiolink. In the older firmware, it detects the internal compass without any problems; after installing the 4.xx firmware, the internal compass is no longer detected. I have all the settings for testing by default. Interestingly, although the rover direction is not detected in version 4.1.5 of the internal compass, it is shown perfectly in the Mission Planner, but the Compass cannot be calibrated and there are problems with the “Bad Compass Health” pre-flight check. I don’t want to run an external compass on the rover when the internal compass shows so well. Did you solve this problem in any way? Thank you for every answer. Jirik.

Uploading: 3.5.2 Compass ok detected.png…

Did you load the Pixhawk1 version of Rover?

yes, i tried both, Pixhawk 1 but also FMUv3.

I performed the test on three different Pixhawks, on one of which a compass is detected.

I add that the compass was detected on a Chinese noname. Pixhawk Radiolink does not detect the internal compass.

Compas detected 4xx.param (15.0 KB)
Compass NOT detected 4xx.param (14.6 KB)

as can be seen from the PDF analysis, neither ACC3 nor GYR3 is detected

analysis.pdf (769.7 KB)