Servers by jDrones

Pixhawk flyaway in stabilized mode with complete loss of control?

A little background.

This flyaway occurred on a dji s900 setup with an authentic Pixhawk fc, dji hardware, and an ImmersionRX Ezuhf diversity receiver. I’ve flown this setup countless times in loiter, auto, and stabilized flight modes without problem. My transmitter is a Taranis Plus with ImmersionRC EzUhf transmitter module. I always fly with missionPlanner open and connected on a ground station laptop and have had success with using that radio connection for flight mode changing / auto mission waypoint selection.

Log and kmz files here and at bottom of document.

Now for the flyaway. Here is a short video clip from partway through the flyaway. The Diversity monitor I was using at the time of the flight didn’t have a DVR so the only dvr I have is when it was already out of sight and I grabbed my FPV goggles and started recording with its DVR. The craft was on an auto mission (~200 meters away) when it suddenly tipped forward and to the right and then started acting very weird (while in auto ie shouldnt have been happening). I immediately switched to loiter which gave limmited control and I tried to bring it back to me. It still wasn’t responding correctly though and so I switched to stabilized mode which still yielded little to no control. The craft wasn’t losing altitude, just not responding correctly to my commands. At this point it had come back and was only about 100 meters away from me at about 200 feet altitude. At this point I could see from its FPV feed, from a hard mounted FPV cam, that my attempts to yaw or roll the craft with my transmitter in all flight modes were not having any effect on it. As the radio was having no control of the aircraft I tried switching the craft to guided mode and flying home via my groundstation laptop with no success. I then tried switching the mode to RTH from the ground station with still no success despite the ground station receiving full telemetry of the aircraft. At this point I switched to failsafe mode on my transmitter, but the craft continued to switch itself back and forth between loiter and stabilized mode rapidly. It passed me at this point in the opposite direction of its auto mission and then seemed to get stuck in stabilized mode and started flying full throttle away at a 24 degree heading (I’ve had the transmitter in RTH mode for a while now). It ended up flying full throttle for about 12 minutes before coming down about 3 miles away. I have looked at the logs in mission planner etc and can’t figure out what exactly happened. It would seem that the pixhawk had some sort of signal loss from the receiver, and that it didn’t switch to failsafe (RTH) when it lost said signal.

Any advice or insight on the cause of such a flyaway would be great!

40.BIN.zip (4.3 MB)

It looks like radio problem. On radio fail you must have it set to go to 1500 for all inputs. The copter simply went with the wind. Don’t know why it climbed and then fell later on other than maybe the battery was lower and it decided to come back down.

Mike

I had a similar issue the other day. Except mine wasn’t switching flight modes before the total signal loss. I was auto tuning the pitch axis when all the sudden I had no control. I didnt get any kind of a warning or anything. I am using frsky hardware and a 9xr pro. Luckily a tree stopped mine, I have not had it happen again and had never had issues before. I also did not have a failsafe setup due to the fact that I had just built the quad and was tuning everything. I hope you can solve the issue or at least figure out what caused it. Let us know if you do.

This is what I thought, but why would it fly at full throttle and 19 meters / second for that entire time. Wouldnt 1500 rc inputs just have it hovering in stabilized mode?

Just a quick thought. When I had my issue The RX was only getting power through the pixhawk, I didnt have a separate BEC powering the rail. I have since added a BEC, redundancy is never a bad thing right? Anyway, I got to thinking that maybe voltage fluctuations could of caused my issue. I have not had anything weird happen since adding the BEC.

Did you ever figure out what the issue was?

Servers by jDrones