Pixhawk First time Calibration Failure

Pixhawk Calibration Failure - please note - i also posted this in the 3.2 forum, but i have had no replies and believe i should have posted here (unable to delete previous post)

My Issue:

I can not complete the mandatory setup procedure for first time setup in APM. When I hit the calibrate button on the radio calibration view I get the error message “radio control is not active or turned on”

The pixhawk is flashing the double yellow signal.
I am getting a voice message saying “PreArm check: RC not calibrated”.

Setup Details:

I just completed a build of the 3DR 2014 DIY quadcopter kit. This is my first build and first time using Pixhawk. I am using APM for Mac and have connected directly (USB cable) or via telemetry radios to APM with success. I (believe I) updated the firmware successfully, and I have successfully bound it to my Spektrum DX7 radio.

I have been following instructions on this page: ArduPilot > APM Planner 2.0 > Calibration: Radio Calibration

I performed the firmware update, which seems to have worked
I performed compass and accelerometer calibrations, which seem to have worked (i did not get any errors),

The radio appears to properly interact with the system as judged by the movement of the green bars in the radio configuration graphical view. I am using this radio Spektrum DX7 7 Channel System w/ AR8000 Receiver Mode 2model SPM7000 (this is a new release of the DX7 ( m spektrumrc.com/Products/Defa … Id=SPM7000) - which seems more like an updated version of the older DX8, but with one less channel). I bound the radio to the receiver and satellite first and then plugged the satellite into the PixHawk. I can manipulate the green bars on the radio calibration screen, but i do not see the min and max red lines as i see in the instructions (i am using APM on a mac).

i am a little worried that because i am using the new DX7 it may not be supported - however the AR8000 is not new and does receive the DX7 signal.

I have tried deleting and re-installing APM but I get the same issue

Please help! I’m so close, yet so far! Thank you. Nick

Update - Issue solved.

i spoke with tech support at 3DR. they were puzzled by the problem i was having - apparently it is not common. They told me that the Mac app “APM is very buggy and they do not trust it”. They told me the only solution was to perform first time calibration using the Mission Planner app on a PC. I sure wish i had known this prior to buying - as i have not seen this stated as an issue anywhere. Anyway - i did find “Mission Planner” to be much more full-featured than “APM”, and it does appear to have resolved my issue.