Servers by jDrones

Pixhawk Faulty Current Measurement on Pin 3

(Chris) #1

as the title suggests I’ve got a problem in getting my PowerModule, well at lest the Current Sensing, to work.
It’s always showing 100A-350A at 0 Current (0V on the Pin). The pin is set to 3 which should be the right one acording to the schematic of my Board (Px4v2). The Value for calculation is also set.
If I let a bit current flow the Value is aroung 1500A which obviously is not right.
I’ve tested it with Copter 3.5.0 and 3.5.1.
So therefore my Question. Is there a way to validate the function of this specific ADC-Pin? Maybe over the Terminal to see the Voltage Readings on the Pins?
Speaking of which I get the following weired Data in the Terminal. It doesn’t seem to be right:

(James Pattison) #2

The first two things I would check:

  1. Make sure you have updated to latest MissionPlanner if you are using AC3.5.x
  2. Have you calibrated the current sensor? Process detailed here:

(Chris) #3

sorry for my late reply but I’ve been busy the last days. The most important fact at first: The Current Sensor is now working fine.
I’ve updated Mission Planner to the latest Version an it worked straight away.
I’ve tried everything but to update to the Current Version of Mission Planner. I’ve even taken the whole copter apart. Fail :upside_down_face:

Anyway. Thanks for your suggestions :grin:

(James Pattison) #4

Great you got it solved! Sorry you had to pull your copter apart: it’s frustrating when you can’t figure out what’s going on.