Servers by jDrones

Pixhawk fails to initialize on battery power, works on USB

(Logan Caskey) #1

I’ve been experiencing a problem with my Pixhawk that began after attempting setup of my ESC with my transmitter. Ever since then, the Pixhawk will power on for a few seconds, the FMU and IO lights indicate they are initializing, then they start behaving sporadically. At this point, the Pixhawk starts cycling power on and off continuously. The tones from the buzzer do not seem to be normal either.

The odd thing is that this only occurs on battery power, and the pixhawk will behave normally when powered by USB. I have even tried with a completely different pixhawk, power module, and battery and it too eventually began behaving this way after some time into getting things set up (but not immediately). I have erased and installed Plane 3.9.8 and even tried previous versions, to no help. The fact that it only behaves this way only on battery and behaves normally on USB makes me think there is an over-voltage occurring, but the output of the power module is reading right around 6V on my meter. And it is occurring on two different Pixhawks, with different power modules and batteries. The only common item between them was ESC/motor and RC transmitter/receiver that I was attempting to setup before each of them began behaving this way. And it seems that no matter what I do now, both will now not function on battery power, regardless of the peripherals attached.

I have linked to video showing power on process.

My setup:
Pixhawk with Plane 3.9.8
4S 1550 mAh battery with common power module
SunnySky X2820 KV800 Motor
Flyfun 60A ESC with BEC capable of 7.4V
3DR radio
D4R-II telemetry

(Joe Breznai) #2

Have you tried setting that ESC to output 5V tp the FC?

1 Like
(Logan Caskey) #3

I checked the BEC voltage and it was set on 5.2V. It turns out to be a battery issue after trying it on yet another battery, and it works this time. Looks like I’ll be getting a new LiPo and charger right now…