Servers by jDrones

Pixhawk digital airspeed sensor + external compass on I2C Splitter

(Adrien Foulon) #1

Hello,

I just finished my pixhawk installation on a Volantex Ranger EX 757-3

I have an external gps + compass module which works perfectly when plugged in the i2c port directly

I decided to add a digital airspeed sensor so I’m now using an I2C splitter

But with this configuration the external compass is not detected anymore, any idea why it’s not working?

I have the latest arduplane stable release (3.9.8 on ChibiOS)

Also I’m using Qgroundcontrol for the configuration and I tried plugging the airspeed sensor only without splitter and setting the ARSPD_PIN to 65 but I don’t see any data related to airspeed on the interface or any new sensor, how can I check that it’s working?

(Mike Boland) #2

It might be an I2C address conflict but have you tried as they suggest
“Note: if you can’t use the item, please change SDA->SCL,and SCL->SDA”

Have you also
" You need to enable the airspeed sensor in Mission Planner | Hardware | Optional Hardware | Airspeed ."
As mentioned in the docs here

(Adrien Foulon) #3

I’m not using mission planner, I’m using QGroundControl (I’m on linux)

But I set the option ARSPD_USE to 1 and ARSPD_TYPE to I
2C-MS4525D0 both are correct for this airspeed sensor

I’ll try to switch the cables if needed but I’d like to know first where can I see the airspeed data in Qgroundcontrol because maybe it’s working but I have no idea

Here are the airspeed related settings

(Marc Dornan) #4

Disconnect the compass from the splitter and see if you get airspeed readings. If so you have a weird address conflict. Compass and Airspeed are usually on different addresses.

The most likely explanation is a bad cable connection though.

Not sure about QGC as I use MP. But airspeed should be very visible.

(ppoirier) #5

Only way to know if working ok is to probe the module with an I2C tool

As with conflicting I2C bus, I experienced some issues with termination resistors on a star configuration, in a particular case I had to daisy-chain the modules

(Adrien Foulon) #6

I’m currently only testing without the splitter, I can’t get the airspeed sensor to work, the cables were completely wrong… The 5v cable was on the clock and vice versa. I put them back how they should be but still nothing…

Any chance I fried it by getting a wrongly mapped cable?

(ppoirier) #7

You can probe with a Raspberry Pi or an Arduino that would really tell if this module is working or not