Pixhawk deploys flap to maximum position on failsafe

Hey all,

I have a Pixhawk clone which I am using with a Bix 3, APM 3.3

Previously setup and flown well using a Spektrum DX6i, however I recently bought a Taranis 9XD Plus Tx and X8R receiver.

In testing, when I turn off the Taranis, APM does its normal fail safe behavior, reverts to circle and then RTF.

However flaps also immediately deploy to fully down, then return to clean, up position upon turning back on the transmitter and receiving RSS.

I disabled fail safe on the Taranis - ‘no pulses’ . No difference, hence I think it is APM related.

Any ideas? Not the ideal state to fly in long distances.

did you happen to have your flap switch on when you set the failsafe on the receiver? try to reset the failsafe on the receiver and ensure all switches are in the right position. I don’t know much about Taranis, but just a thought.

Thanks for the input, I tried rebinding the rx with the flap switch position in retract but with no luck in changing the behavior.

I noticed in the radio calibration screen the channel six PWM dropped right down when I turned off the Taranis, even with the Taranis set to ‘no pulses’ in the failsafe mode. Next I tried ‘hold’ which corrected this, however frustratingly the flaps still deployed.

Luckily I brought up the issue with a friend who suggested reversing channel 6 direction in mission planner and reversing the direction on the Taranis so the switch would still operate in the same direction. And it works! Flaps no longer deploy on loss of signal from the tx! Hopefully this helps someone in the future struggling with the same issue.

It doesn’t sound like you’re properly setting the failsafe on your receiver. Which Frsky receiver are you using? You are setting failsafe through the first page of the model on your Taranis correct?

Personally, I don’t recommend the “no pulses” failsafe model for APM:Plane. I recommend configuring every channel exactly where you want it and setting that for failsafe. That way you would (for example) have flaps, camera switches and whatever else you have on your plane in the right positions when failsafe happens. All of the Frsky receivers support failsafe on all channels and can give this richer behavior.

For triggering failsafe behavior on the Pixhawk, I use a fail-safe throttle value of 950uS with normal low throttle set to around 1000uS. To make setting failsafe easy, I set up the momentary switch to force throttle to that position and then just use that when setting failsafe for the receiver.

Thanks Noircogi, I’ll try to configure failsafe with your recommendations.

Hi :slight_smile:

did you manage to solve this problem?
It looks like I have the same problem.

I have a 7kg motor glider with ailerons and flaps. Large 4m wing.
I use Spectrum DX9 RC transmitter and Spectrum AR9320T RC receiver.

I have the failsafe activation done with a low throttle in Pixhawk, when the RC transmitter turns off, the PWM signal drops to a very low level which activates the failsafe. It is working.

What is amazing, the flaps (they are on channel 5) when autopilot is entering to the failsafe mode fall down.
This is dangerous because when the motor glider is flying in AUTO mode in a mission and the RC communication breaks down, autopilot opens the flaps, causing a slight stall. Of course, the plane continues its mission in AUTO mode all the time.
My normal position of the flaps is a PWM of 1845 (maximum)- in this position, the flaps are used for normal glide flight. When I turn off the RC transmitter the value of “ch5out” = goes to 1100 (minimum). I read that the input signal “ch5in” is still at the same level = 1845 as before.
It looks like the autopilot is doing something after triggering failsafe with flaps.
In the RC receiver I use “Preset Failsafe”, which is a mode which, after breaking communication with the RC transmitter, sets all channels to programmed positions. I have carefully programmed all servo positions (e.g. flap position for gliding, mode switch to auto mode …)
At this point I am not using the flaps in AUTO mode. I only use the flaps during take-off and landing and trigger them manually when I want to (take-off and approach to landing).

I have reviewed all the parameters of the flaps and we have no idea anymore with my colleagues.
Does anybody have an idea?

Best regards,

The problem has been solved, the flap chanel 5 reverse operation on the RC transmitter helped.