Servers by jDrones

Pixhawk Cube (2.1) relay pins?

Hi All,
I can’t seem to find conclusive documentation of which pins can be used from the Pixhawk Cube for relay control.
I’m trying to control 5v relays. Can source the 5v elsewhere if needed. I’ve tried every combination of pins and parameters I can find. Mission Planner 1.3.58 build 1.3.6794.30567. Any thoughts?
Thanks heaps!

Does this help:
Also power the 5v and 0v pins in the AUX out bus from an external BEC.
I think everything about the cube should be the same as in the doco (pin numbers in MissionPlanner and so on), just the picture of the physical Pixhawk is older.

Thanks @xfacta, tried those pins. In MP tried them with the Pixhawk Aux out and also the Pix FMU and Pix I/O. Had 6V and gnd from the pins of a beaglebone blue. Thanks for the idea :+1:

Can you share your project settings and connections? I’m having same issue with relays. How can I test relay outputs manually?

From memory, my biggest problem was not powering the servo rail. Once it’s got an external power source connected you can test the switching of the outputs. On the main flight screen there’s a servo tab. Under that they are listed in order. Toggle there.

Thank you for your kind answer. I got relay working manually, but it doesn’t work with automode. I’m not sure about the connections or settings. I try to do skid steering or ground steering with relays.

Now finally got it working. I had wrong kind of relays.

1 Like

hello i have the same problem with a skid steering vehicle and relay pins.Can you share your configuration?thanks

Pixhawk2.48.param (8.5 KB)

Servers by jDrones