Pixhawk/Crossfire/OpenTx X7s

Morning all,

I would like to think that having years of experience with the Pixhawk family, I would be able to figure out this issue I am having.

However, you know what its like to get halfway into a project and then come to a frustrating sticking point that you can’t for the life of it work out. I currently can’t get CRSF working, Telemetry is another issue

I will say I am a new TBC Crossfire pilot having come from ImmersionRC suite.

I just however cannot work out the simple combination of having:

Crossfire → Pixhawk via CRSF – RC Control (Telem1)

Crossfire <-> Pixhawk – Telemetry (Telem2)

I have spent many hours searching through posts, watching videos and making many changes… I can only now assume that it’s something I am not understanding. On paper it should be very simple!

Here is where I am at:

  • Crossfire (Full crossfire with Bluetooth) – Latest Firmware
  • Crossfire Nano diversity – Latest Firmware
    • Have also tried another nano diversity and nano
  • Mission Planner – Latest plane Firmware

OpenTx Setup (QX7s)

  • Model set up, CRSF 150Hz mode, external
  • Binding with the Crossfire is not an issue
  • Model set up A/T/E/R

Mission Planner Setup

  • Telem1 & Telem2 Port, set to RCIN (23)
  • RSSI, Option 3
  • BAUD, Option 15 (11500)

Crossfire Setup

  • Mavlink by RC – ON
  • Channel Map
    • Output 1 CRSF TX
    • Output 2 CRSF RX
    • Output 3 – The documents say it should be MAVlink RX
      (Mine will only let me select MAVlink TX)
    • Output 4 – As above
    • Output 7/8 – RX & TX (Without Output3/4 selected)

Wiring Setup

  • Pixhawk to Crossfire
    • Telem1 Pin 1 (VCC) - Crossfire Pin 2 (VCC)
    • Telem1 Pin 6 (GND) - Crossfire Pin 1 (GND)
    • Telem1 Pin 2 (CH1) - Crossfire Pin 3 (CRSF TX)
    • Telem1 Pin 3 (CH2) - Crossfire Pin 4 (CRSF RX)
    • Telem2 Pin 2 (RX) - Crossfire Pin 8 (CH8) – Output Map 8 MAVlink
    • Telem2 Pin 3 (TX) - Crossfire Pin 7 (CH7) – Output Map 7 MAVlink

Now this is just to get CRSF working within Mission planner for RC control.

I have checked my set up countless times. I don’t know what I am missing to get this working.

I won’t even go onto the Yappu telemetry not working yet (Yes CRSF is selected in the script). I just can’t even get CRSF working as it should for RC link.

I have gone through all the TBS documents, forums searches, videos you name it!

I would really appreciate some fresh eyes as I think I am loosing the will to live!

Thanks so much!

If this is Pixhawk1 1-M then CRSF telemetry is not built into the firmware because of flash constraints - you will need to use the custom build server to get a version that has this feature

Thanks Andy,

I will look into that. Pixhawk1 should already have the CRFS protocol though, just for RC control? I still cant get that to work either!

Your snippet of information will come in handy, thank-you so much!

You say you set “MAVlink by RC”, but perhaps you meant “RC by MAVlink”? If so, might that be in conflict with trying to use CRSF for RC (per your output one and two settings)? In any case, I think RC by MAVlink is only intended for 100% ground-station control, since the update rate is quite low.

I think I have confused myself, I agree!

I have got RC link now with the simple Channel Map.

  • Output 1 CRSF TX
  • Output 2 CRSF RX

I have watched and read so many things that I am starting to confuse myself.

Should I not have CRSF on Ch1/2 and Mavlink on Ch7/8 as the output all through UART (Telem1).

Am I mixing both RC control with CRSF and RC control with Mavlink?
The way i read is that:

CRSF is RC control
Mavlink is Telemetry

Thanks for your reply Robert, i really do appreciate it

CRSF is RC AND telemetry
Mavlink is bidirectional telemetry and command (you can send commands to your plane)

Right, you can use MAVlink for telemetry alongside CRSF for control if you want, but CRSF will do both if everything is set up correctly (on some boards you have to set BRD_ALT_CONFIG).

Even if on Ground Mission Planner or QGroundcontrol is to be used on mobile phone or laptop?

I think that only works if you configure Mavlink additionally or use RC over Mavlink.

Could be, I’ve never had any luck with that, but I haven’t tried since I got the CRSF telemetry working correctly by setting BRD_ALT_CONFIG.

But mavlink is higher latency and the thread runs at a lower priority, if you want the tightest manual control then use CRSF