Pixhawk clone 2.4.8 - motors not running in the same speed!

Hi, I Built a Hexa with the chinese clone FC, 6s, 360kv motors and a Tarrot frame.

My copter kept flipping backwards and the compass moved in the opposite direction to the copter. Moreover, compass just did not calibrate no matter what I tried, the only way was to use the Large vehicle mag calib option. Suspecting faulty motors, I changed two motors and rechecked connections, board orientations, prop spinning, esc calibration etc. and unable to get it off ground and 6 propellers later, finally replaced the FC.

The new FC (also a clone), seemed to have no issue, the compass moved in the right direction, was able to calibrate compass without any difficulty etc. But when I try to take off, the hexa tips frontwards and hits the ground - 30% power. I rechecked props, motor directions, recalibrated esc, checked if the autopilot compensates in the right direction by simulating pitch, roll, yaw, rechecked CG.
After all checks I tried to test fly, the same happened!

So, being super frustrated, i checked the logs to find out that motors 1 and 5 (very similar in the graphs) run significantly slower than the rest, while motors 2 and 6 (very similar) run faster than the RCIN, and 3 and 4 to an extent follows the RCIN.
suspecting faulty motors, I switched the motors to try and run it, but no change! Surprised, I tried doing more switching of motors, but it all yielded the same results. In general (with slight variations in the graphs when swapped) 1 and 5 runs much slower and 2 and 6 runs much faster!
Suspecting faulty esc, I then tried changing the RCOU! switched 2 and 1…but still the same result!
This pattern is the same when kept on a leveled area, when I try to simulate pitch ( more than 30 degrees approx.) I see that motors 1 and 5 does run muchh faster, meaning they are able to run but is limited by the FC! and I could also make motors 6 and 2 - run at the minimum!

Now, what should I do to make all motors run at the same speed! What are the possible reasons why it behaves this way?! Am I doing something wrong - this the first time I am touching a drone in my life (First time I am using MP, Arducopter, pixhawk etc.) I began building it this Month! I finished building in one week, and I have spent the rest of the time in analyzing and trying to change parts! I am super frustrated at the moment! Please help!

PS - I kinda am a messy person so my Logs are all over the place and have not named them properly, hopefully, I will sort them out and will paste the BIN soon!

Edit -

So, I tried testing it again, recalibrated everything, double checked the prop and motor direction. I did take off without a GPS lock, I don’t know if that can cause the drone to flip. Please advice!

Video of whatever is happening: https://vimeo.com/776652203

Log:
test flight fy 680.bin (135.9 KB)

it sounds like you have the motors connected in the wrong order.

1 Like

hexa motor layout

@geofrancis
I have used this as a reference and connected the motors accordingly…
If this wrong, can you please direct me where I could find the right order?

Even so, shouldn’t all motors run at the same or similar speed? 1 and 5 run close to their minimum when kept on a leveled area, while 2 and 6 run close to their maximum…

That is the Motor connection order, but it needs to be tested with the “motor test” buttom of mission planner.
And the motor test order is not 1, 2,3, 4, 5, 6.
It is A, B, C, D E, F

Please read the documentation more carefully.
https://ardupilot.org/copter/docs/connect-escs-and-motors.html#testing-motor-spin-directions

And ignore the motor speeds when testing with a remote control with the copter sitting on the ground. ArduCopter is a closed-loop control system. It can not be correctly tested in an open-loop way (RC receiver while sitting on the ground)

It can however correctly be tested in an open-loop when using mission Planner`s “Motor test” buttons.
We explain this exact thing twice a week, there must be dozens of posts on this forum explaining this !!!

1 Like

I don’t know if this is normal, but Motor A corresponds to motor 5 and proceeds clockwise,

Like this -

hexa motor layout

I have done tests in the past through the motor test button of the MP to test motor and prop direction… but admittedly have not checked the logs to see to check if there is a difference in motor speed.
I will do another test using the motor test in MP and update.

While I have read that tying the drone to the ground and the likes will not yield perfect results I began propeller-less ground testing just to check if the autopilot is reversed. But I did not know that even motor speeds can vary so much if tested with copter on the ground. Thanks.

First thing - upgrade to latest stable firmware before doing anything else, version 3.6.8 is very old now.
Select the flight controller as Pixhawk1

Next thing - don’t rush into jumping down my list to ESC calibration and and trying to arm and fly again - work through all these things in order.

Put ARMING_CHECK back to 1
Also set
BATT_FS_CRT_ACT,1
BATT_FS_LOW_ACT,2
MOT_PWM_MIN,1000
MOT_PWM_MAX,2000

Check your radio failsafe works by turning off your radio (no need to connect a battery and arm or anything dangerous). MissionPlanner should show a radio failsafe message or even No RC receiver.
These are the related parameters
FS_THR_ENABLE,1
FS_THR_VALUE,950
Your receiver (and maybe transmitter too) must be set to no pulses, or -120% throttle channel if it only has set outputs. Read the receiver doco about binding and failsafe actions. Check with us if you have to.

Battery
BATT_CRT_VOLT , BATT_LOW_VOLT and MOT_BAT_VOLT_MAX/MIN are set for 6 cell yet the battery you are testing with is about a 3.5 cell - somewhere between 3 and 4 cell voltage range but neither. What battery do you actually have?
You may just have to calibrate the voltage sensor by accurately measuring the battery voltage with a digital multimeter, and put the measured value into MissionPlanner Battery Monitor section as per
image

If you have to, connect to MissionPlanner, Initial Parameters and use that to update your battery failsafe and MOT_BAT values to be correct for your battery cells and chemistry.
In my experience, the testing phase is where you need your failsafes and everything operating correctly. Disabling some arming check or battery voltage failsafe because the copter wont arm is just trying to jump the shark - it will end bad.

Calibration
It might be a good idea to redo the radio calibration too, or at least check in the radio calibration screen that everything is working as planned.
Level the copter by packing under the landing gear so it is perfectly level across the “prop disc” (dont worry if the flight controller itself is level or not) and in MissionPlanner / Mandatory / Accel… press Calibrate Level. Dont assume some surface you put the copter on is level, or that the landing gear and frame are all equal/level/straight/true.
Recalibrate the compass by going outside, wait for a good 3D Fix with the GPS (MissionPlanner HUD will say 3D Fix, don’t rely on the GPS LED) then do the compass calibration.

Motors
You diagram is correct - If you Test motor A and motor A on the diagram runs, and so on around B, C…
then that is correct. The All In Sequence button is a good test when you think you’ve got it right.

Do the semi-automatic ESC calibration
https://ardupilot.org/copter/docs/esc-calibration.html#semi-automatic-esc-by-esc-calibration

Don’t even bother to arm and test motors inside the house or workshop by disabling arming checks - just use MissionPlanner motor test, or go outside and fly.
Always wait for a good 3D Fix - this can be tested 2 ways:

  1. set FENCE_ENABLE,1 ← this seems slow but is safest
  2. select mode Loiter and wait for green LED, then change to whatever flight mode you want ← open to human error
2 Likes

Thank You soo much!
It flew!! After 2 weeks of breaking my head…

Thank you again!!

2 Likes

Thank you all three of you for contributing!

Have been flying rc planes for more than 10 years now, and tried using my half-baked knowledge in drones! I think an advice to everybody who is starting out or switching to drones would be to read the instructions properly and follow them first before experimenting with things!

2 Likes