Servers by jDrones

Pixhawk can't be unlocked using pozyx


(Tangap) #1

Configuration through the Ground Station

Ensure that Copter-3.5 (or higher) is loaded onto the flight controller and connect with a Ground Station (i.e. Mission Planner).

set BCN_TYPE to 1 (means using Pozyx system)
set BCN_LATITUDE, BCN_LONGITUDE and BCN_ALT to match your actual location. Getting these values exactly correct is not particularly important although getting it close is required in order for the compass’s declination to be correctly looked up from the small database held within ArduPilot.
set BCN_ORIENT_YAW to the heading from the origin anchor to the 2nd anchor. One way to capture this value is to stand at the origin holding the vehicle so that it’s nose points towards the second beacon. Read the vehicle’s heading from the HUD and enter this value into BCN_ORIENT_YAW
set GPS_TYPE to 0 to disable the GPS
set ARMING_CHECK to -9 to disable the GPS arming check
set SERIAL1_BAUD to 115 to set telemetry1’s baud rate to 115200 (if using Telem2 set SERIAL2_BAUD instead)
set SERIAL1_PROTOCOL to 13 to enable reading the IndoorLoiter2 protocol (If using Telem2 set SERIAL2_PROTOCOL instead)
set BRD_SER1_RTSCTS to 0 to ensure telem1 does not use flow control (If using Telem2 set BRD_SER2_RTSCTS instead, not required if using Serial4/5)

I have tried to do Pozyx configuration through ground station.however,I found a problem in the test,my aircraft can’t unlock and always report GPS glitching,how to solve this problem? Thank you.
1