Pixhawk battery voltage drifting in Mission Planner

I have a Pixhawk mounted in a FBL helicopter running Firmware v 3.4.6. Using Mission planner v1.3.48. I’m having problems with the battery voltage drifting. I set the battery monitor in mission planner and it shows the correct voltage, at first. If I leave it swiched on, on the bench, the voltage drifts up or down by a couple of volts. I’ve tried other power modules and are getting the same problem.
Has anybody else had this problem? that can offer me some help.
I have three other Quads with Pixhawks and never had this happen before.

Hi OAPpilot
Are you using the same sc as in your previous experiences?
It is common that non-isolated ESCs generate interference in the measurement voltage (with the power module)

The sc is about four years old.in this Heli, It’s had a 3DR pixhawk, APM, and now this pixhawk. Even with this Pixhawk the voltage has been OK. Started playing up round about the time I installed this firmware.
It’s as if the input voltage keeps getting changed in the battery setup in mission planner. When I look at it the input voltage has increased or decreased.


Thinking out loud - maybe one thing you could is measure the voltage on the cable from the power sensor to the pixhawk manually with a voltagemeter or osciloscop - that would give you a independent reading of what is going on and would help determine if the issue is upstream from your measurement point (so the sensor or the battery) or downstream (so somehow related to the px).

Just a thought…

Hi Christian
I’ve checked the voltage output from the 6 wire cable on both 5+ pins I’m getting 5.27volts. On thr V wire I’m getting 1.19v with a 11.9v 3S lipo and 1.23v with a 12.2 Lipo. If these numbesr are muiltpy by X 10.1 the result are about what you expect to see in Mission Planner, but they are showing lower and then higher after time.
How does mission planner handle this input to give these results?

The combination firmware 3.4.6 with mission planner 1.3.48 has been without problems.Discarding that there really is not a connection problem (Loose connection), I think it is not a problem of the mission planner, because the indication in this is only information received from the pixhaw.
These tests at the bank are with the motors running?
Just to confirm that it is not a problem of the MP, try with a previous version. Also verifies that the calibration in the MP is correct for the components you have.The battery monitor, in this version, brings several additional alternatives

It looks like the problem might be solved. I made up a new 6 wire cable, and things have settled down. The old cable came with a power module I purchase of the internet, all the wires were black. It looks like the red wire(black) was on the wrong side of the plug.
Thanks for the help you gave me.

Hello, I have a similar issue, have a look here…