Pixhawk Baro Sudently Jump

HI, guys i have a problem with the altitude
it sudently jump over 54 meters high (not ASL if ASL must be over 600m)
is this h/w problem? or any parameters i have to take a look at?

What about posting the dataflashlog ?

Thank’s Andre-K

i tried to get DF but so much failed d/l it over the radio, yeah i know i must to get DF to be sure, please wait…i will get the DF somehow

but meanwhile is there any guess theory about that behave? :slight_smile:

Just extract the Micro Sd card from your Autopilot to get the DF logs .

wow thanks i’m not realize that, supersimple thank you !!

here it goesssss…

https://drive.google.com/open?id=1wyFVI7LFHvCl2FQ7A8Q0t2wWhq_rpI2E

hopefully get fast answer, because i will try to flown again tommorow, & if it behave like that again i can’t send the plane far :frowning:

You are using a quite old version of Arduplane.

I do not see any problem with altitude, no jumps.

I guess it is a problem related to telemetry or Mission Planner.

hmmm…that’s weird, no it’s not just telemetry false reading
ahah can you explain that 200m? that was at cruise mode, and it raise it self (climb) for no reason, thats what i;m worry of, if just false read i;m not that so concern

edit:

that’s why i change imediately to FBWA to bring the plane down
that “GLITCH” effect the cruise & the RTL that’s why i’m so concern want to know what it cause before send the plane far (out of my sigh)

omg, i;m so embarrassed i thought my AP is 3.7
thats must be my another pix :frowning:
i;m so sorry with this wrong sections of this sub forum

When you chage to FBWA the plane was at 56,5 meters not 113 meters.
Have you note that the “jump” is exactly the double of 56,5 meters ?

Do you have a pixhawk 2.4.8 with wrong baro reading 500hpa instead of 1000hpa ?

hi kiki i guess like lucamax showing the graphs of the altitude nothing wrong with the baro sensor, and yes it’s more likely false reading

i guess i have to change the subject, yes i know it is just a false of alt reading
but why FC obey that “new” altitude instead of the real altitude

yes you are right, now i know why she climb thank you :slight_smile:
but still the questions remain, why FC obey that false alt there is no hill, it just flat big field when she sudently climb, but today i realize as you noticed me the version of the AP was too old, i decided to upgrade with a new 3.8 but wow why there is no “VTAIL” parameters :frowning: so i downgrade again to kast version (3.6) & just reset to default then reupload last parameters and just hopefully that problem dissappeared

V-Tail planes are still supported :slight_smile:

With 3.8.4 The Rc inputs and Servo Output are totally independents and you can assign to a servo output whatsoever function .
For V-tail planes , typically servo 2 and 4 will have 79 and 80 for SERVOX_FUNCTION:

gkrellShoot_01-04-2018_043806

V-tail setup is explained here : http://ardupilot.org/plane/docs/guide-vtail-plane.html

I think that your plane climbed because of low airspeed and because you have something really strange in your setup.
I may be wrong but if you look at the take off , the plane climbs but RCOUT2 and RCOUT4 that should be the elevator outputs remains close to 1500ms , so only the motor at full throttle and your COG or your elevator trim make the plane climb.
Then in Cruise mode sinceyou have 11ms as Arspd_Fbw_Min and a quite powerful motor/propeller the plane tries to hold the 13 ms that is your trim speed, but because of wrong setup with throttle increase the pitch increase so the airspeed go down and the Autopilot increase throttle again.
Did your battery got loose during flight ?

i’m sure there is :slight_smile:
but i don;t have much time to digging the informations, i’m runout of time, i’ll upgrade again and do some learn with new parameters after i flown again today :slight_smile:

hey i just realize that too hmmm…it weird but it seems because i’m limiting the pitch to 25 degree thats why AP not giving more UP because it’s already UP (i’m using auto takeoff)

low airspeed & climb ? sounds i was wrong get informations, ussualy low airspeed make AP decided to dive instead of make a nose up?

oh yes big heavy plane with big battery but low “C” rate, so that was not loose the battery but because i used 15c of 4s 10ah battery :slight_smile:

this is the entire story of that moment :slight_smile:

BIG thank’s lucamax i;m appreciate your though & input it’s so pleasure to have that input from the expert, i’ll do test again in a few hours, i’ll reported again if she have a same problem as before

By “got loose” I mean that your battery moved back during flight so the plane become tail heavy .

ah i thought battery connector got loose
i’m prety sure it very tight, i never use just a vecro but with also with the strap
oh well this talon was glide well she refuse to stall nor to nose dive, always glide and reduce the altitude slowly

btw, i guess i solve my problem
don;t know which one which cure the problem is :slight_smile:

but let me explain
1st, this behave show up when i replace the GPS (i never thought there’s any correlation) but nothing else i did change, it never had a problem before

so after that alt faulty, i;m doing this

  1. i reset to default & put back my last saved parameters
  2. i change the parameter “ALT_MIX” from 1 to 0.5
  3. i put for a while the plane (5 minutes) just sit before takeoff

and today result is so flewlessly, even facing high wind :slight_smile:
thank you lucamac i close my case, i think i’m satisfied enough with this result

CASE CLOSED

ALT_MIX ?!
Watch here
https://github.com/ArduPilot/ardupilot/issues/3149

There was some altitude reference selection changes that were fixed in v3.8. please upgrade.