Pixhawk avionics voltage low warning

Hello drone experts!
I’m building a x500 readytosky kit.

Lots of small issues getting started but finally attached esc and motors to autopilot to do all in one calibration.

The ESCs are cheap readytosky simonk 30A.

Firstly I couldn’t follow the throttle up- disconnect+reconnect battery-safety switch-throttle down instructions from many videos and manuals.

It seems I am not getting my pixhawk into calibration mode, maybe transmitter signal is not a high enough max or pixhawk is not getting the message.

I did succeed with one by one calibration with the TX and RX straight to esc, and used qgroundcontrol usb calibration setting.

I can arm the copter with safety switch and TX arming switch, and the motors all turn fine (maybe not turning quickly but I don’t know until I install the props)

However qgroundcontrol gives a low avionics warning message: 4.81v so it appears the pixhawk is not getting enough from the power module.

Power module was supplied as part of the readytosky kit, xt60 to 3s battery, 6pin cable from regulator to pixhawk, xt60 to pdb.

When I power the pixhawk from an ESC the voltage is lower, about 4.4v, and the Rx confirmed 4.4v while calibrating escs.

When I power from usb cable the pixhawk also complains about low voltage.

I have calibrated the battery but not had a serious attempt to change amps per volt setting ( I did enter some other values to see if I could affect to avionics voltage but it didn’t change and that’s probably cheating!)

Anyway, I think I might be able to fly on 4.8v but it’s worrying me.

Should I try to reset pixhawk by holding safety switch while powering then recalibrate while powering off a battery rather than usb?

I am not so sure that you should directly calibrate ESCs directly from RX bypassing the pixhawk.

Until which state can’t you follow the ESC calibration via pixhawk?

For the low voltage problem, have you tried measuring the voltage at the power module with a multimeter?
We have some bad experience with a bad picoblade cable that most pixhawk 1 uses (I assume you use pixhawk 1.) The wire strand was very poorly crimped at the terminal causing a lot of resistances resulting in a voltage drop.
Try checking the output from the power module first. You should get 5.0V+
If you get 5V+ then check the pixhawk reading. How many V does the pixhawk reads?

If both are the same, and you still gets low voltage, try disconnect all peripherals then check again.

That is a good solution, I couldn’t get my probes into the power cable but I checked the servo cable from esc to verify 5v.

I was on px4 firmware and I changed to apm and that solved the problem, I calibrated escs exactly like the YouTube videos.

The seller suggested I plug power cable into another 6 pin port on the board and it does read 5.1v.

Thanks for your help :slight_smile:

1 Like