Servers by jDrones

Pixhawk Auto Tune not working? Help with a log please! =)


(Nik Barkley) #1

Hi guys, can I get someone to look over a log for me? I don’t know what I am looking at yet when it comes to these. but I just tried to fly an auto tune in loiter mode on my PixHawk 2.1 copter with APM 3.5 installed, and it basically just flew around in a big circular radius for 20 minutes until it ran out of battery and crashed (I don’t yet have my power module setup for batt failsafe) It looked like it was auto tuning judging by the radius it was flying, and it was also turning itself around to keep the front of the aircraft toward center… but i never saw it actually do any pitch, roll or yaw turns for the tuning portion of it all.

Any insight into this log would be great, thank you!


(Nik Barkley) #2

I also want to add that, I ran an auto analysis of this log and it is telling me that I have a GPS glitch, and MAG interference? I have calibrated the compass and all the sensors multiple times… I keep having issues with the external compass not wanting to calibrate very well… If I use QGround control, the best calibration I can get is the middle of the yellow bar… or it plummets and goes to the red zone which is no good. I do not have my GPS on a mast to lift it up off of the frame, would that be my issue?


(Hari .P) #3

The external compass is inside the GPS unit. Use a GPS stand to move it away from interference, and do a compass calibration.
If you don’t have that much flight time to do roll, pitch and yaw tuning, do 1 axis at a time.


(Nik Barkley) #4

Thanks Hari, I appreciate your response. Can I get a GPS mast from any hobby shop or online store?


(Hari .P) #5

You can even make one !


(Hari .P) #6

_emphasized text_as I am interested
Can you post a an image of your setup ?
Frame size ?


(Hunt0r) #7

You have posted this in the “Hardware” forum, but you may get more response posting in the “ArduCopter” forum instead.


(Nik Barkley) #8

Thank you, didn’t think about that being a better place to post it