Pixhawk armed - motors fail to start

I am sorry to report after a day of multiple perfect PIXHAWK performances in Stab, Loiter, Alt hold, Drift, mutilple missions + ROI… The motors failed to start on the final intended flight.

With battery plug in, it booted up with red-blue, musical tones, yellow blink, green blinks with flashing switch light.

This time when I pushed the switch, there was NO TONE, but went to solid red and there were no motor arming tones… The solid green light, arming tone and telemetry verified arming… no failsafe messages. It disarmed normally with tone and telemetry.

There was no motor slow start this time, and throttle stick got no response…

I have reloaded 3.1 then 3.1.1rc2 with same results. I have re-calibrated the radio. The speed controllers and motors all work with direct rx output…
Anything else to try?

MP 1.2.93
FW 3.1.1rc2
4S with 4000 packs
Latest Pixhawk
Futaba radio

I really hate to see this, it really does fly very well…


Can you post a tlog or dataflash log?

It sounds to me like it’s probably not a flight controller issue but rather an ESC issue.

It might be good to remove the Pixhawk from the frame (or at least detach the lines to the ESC) and connect a separate servo or ESC+motor to one of the pixhawk’s outputs and see if it’s works. Basically I’m just trying to think of ways that we could test if the Pixhawk is outputting a pwm value on the output pins. Another way to test would be to use a servo tester.

Hi Randy

I have done as you suggested…

I pulled the pixhawk off the machine
Used another controller and motor into the output rail…
Attached the gps compass another power module, switch and buzzer

With telemetry module, battery plugged in and normal power up process
Again with arming–no motor

On occassion if connected USB and booted, then connected battery, then removed usb… got motor tones and slow start worked…

When I repeated this process I got nothing out of the motor but the controller gets hot quickly… I have gone thru this process many times now any have only got motor response a couple of times…

The whole time I never get arming tone from the motor when I push the switch.

All this is mess is new after many successful boot ups and flights yesterday…
I think this is hardware problem.


This is the only sequence that gets the motor turning:

boot the pixhawk with usb only plugged in computer
Push arming switch, solid red
then plug in battery, arm, motor sings
then motor starts with throttle
the motor does’nt work unless usb is plugged in… does’nt have to been connected to MP

loaded ac3.1.1 nice

It might be good to post a video. Do you have the ground connected from your ESCs to the Pixhawk?

Thanks Craig,

I don’t know… I worked all day Sunday with this frustrating problem with all combinations of trial and error… . I had 2 days of excellent flying service, then, with all things the same, suddenly nothing… I am ready to request an RMA and maybe you guys can dissect this Pixhawk…

Objectively, the Pixhawk is a fantastic improvement and I am eager to get one back in the air…

Thanks for all inputs…

Please post a photo and or video of your setup. I’m sure we can save everybody a bunch of time

I just couldnt give up yet… here are some videos I hope will enlighten my situation… items present are switch, gps, buzzer, speed controller int mot1, 1 servo into aux1 for tilt control(which works all the time) via ch 6

This is the way it acted before the the final flight was attempted…

After lots to trial and error, this sequence is the only way to get the motors to go… Once I have gone through the sequence once, I can disconnect the USB port and it will still turn on with the radio and battery connected…


I have exactly the same issue.
I get the arming and disaming tone (Blinking green and solid green led) but the motors won´t spin up.
Maybe its a problem of the bootloader?
How can we reflash the bootloader?
The point in MP (Initial Setup/PX4 Bootloader) is also for the Pixhawk?
I would like to flash the bootloader.
My Hexa flown before very fine with 3.1.1 RC2 but after upgrading to 3.1.1 final no motor response.
diydrones.com/forum/topics/p … ter-arming
here I attached a normal log. The Signal is on RCout but no spinning of the motors.
I did not change anything in wiring in between.


If I put a servo into motor1-4, push the switch button, the servo activates, rc arms as expected, and the servo moves with the throttle stick…
So there is a pwm signal out the motor ports… Why won’t the controllers arm except with booting using USB?


Maybe the ESC’s are timing out waiting for the PWM signal. Try booting up on battery power, and immediately pushing the arming button. Then arm. See if that works.

I’ve heard some ESC’s timeout if they don’t get PWM within 10 seconds.

[quote=“Rob_Lefebvre”]Maybe the ESC’s are timing out waiting for the PWM signal. Try booting up on battery power, and immediately pushing the arming button. Then arm. See if that works.

I’ve heard some ESC’s timeout if they don’t get PWM within 10 seconds.[/quote]

Oh many thanks for your answer. I am digging since 3 days. It is not so fine that the original 3DR ESCs have this issue. Is there a more elegant way to flash them with another firmware? I am not so experienced in soldering very small parts. Or did we get a bug fix via Firmware?

Many thanks


I really can’t see your wiring setup in your video, but given we have several hundred copters wired up with these ESCs I would be pretty surprised if it was a firmware issue.

This is a genius working…
Rob_Lefebvre, you solved the issue… motor STARTS if i push the switch within few seconds!!!

Thanks for everyones help

Wiring should not be the problem. It worked well at the beginning of my flights with 3.1.1 RC 2. The problem starts with 3.1.1. and going back to 3.1.1 RC2 didn´t solve it. I played a litle bit with qgroundcontrol in between. Maybe the problem is located on the IO board, but for me it is not clear how this is updated. Or maybe I updated it with qgroundcontrol and can´t be downgraded to the 3DR version? Or are they the same? I did not found much documents regarding to this. And btw. I am using the old 3DR ESC´s which I bought around two years ago from 3DR. Not the simonk version.
What is stored on the IO part of the Pixhawk. Maybe you can give me a link e.g.