Pixhawk ardurover aux relay Output Problem

Hi ,
anyone can help me with this problem

tryed ,googled,etc overs week,unable to make AUX output to be Relay (Need 1) on Ardupilot Pixhawk
(want RC7 to enable relay on aux port,at this time,switch seem to work but in Servo Mode 50hz,.334v…
Hardware 4.2.8

message in mission planner

ArduRover V4.2.3 (2172cfb3)
: ChibiOS: 38022f4f
fmuv3 00380017 34315103 32343336
RCOut: Brush:1-8 PWM:13
IMU0: fast sampling enabled 8.0kHz/1.0kHz

Thanks in Advance (helpp!!!)

Try this:
RC7_OPTION (28) for relay 1
RELAY_PIN (50) for AUX 1
SERVO9_FUNCTION (-1) for GPIO on Aux 1

Thanks For Your help,

it’s seem to work but it gave me only .336v (50hz) ,how to remove PWM ?

many Thanks
(no command in full list for BRD_PWM_COUNT)

This control is now implemented by parameter SERVO_GPIO_MASK from version 4.2 and on:

Complete Parameter List — Copter documentation

That might depend on whatever else you have configured on the AUX ports.

Thanks BrunoBagarini and dkemxr For Your Help,

SERVO_GPIO_MASK set to servo9 to 14 work !

if i uderstand, now my aux act as GPIO Only ?
(tryed to check servo9 only ,servo9 and 10, and doesnt work.

But, i have what i want.

Many Thanks!!!

Nice man! Keep pushing!

Only the ports with bit one inside SERVO_GPIO_MASK set to 1 will act as GPIO.

Be sure that their SERVOX_FUNCTION parameter is disabled and these pins are not used for anything else.