Pixhawk ArduCopter 3.5.3 "Bad Logging"

I know there’s a few of these topics with same name but everything that’s written didn’t work for me.
I have a PixHawk PX4 mounted on octaquad. APM was before, but then I decided to level up.
I’ve worked with pixhawk on a test quadcopter and after struggling with “Bad AHRS” and “Compass variance”, everything worked great.

This morning I started my octaquad, everything looked ok, but then “Bad Logging” and “No IO Thread Heartbeat” arrived. I did everything from other topics and nothing worked.

  • changed file format on my SD card (8GB class 4)

  • changed every LOG_BITMASK type

Does anyone know any other option to work this out?
Thank you

Is this chineese sd card? trash one and buy sandisk

Used 2 SD cards with same result… Tried third one, and everything works. Thanks :wink:

Also make sure your LOG_BACKEND_TYPE is set to 1. Some have inadvertently changed this and unless you have a companion computer 2 or 3 will not work.

I’ve set LOG_BACKEND_TYPE to 1, and also LOG_BITMASK to 655358. Thanks for concern

Hi there
I had a similar issue.
Taking the micro sd card out of the Flight Controller (PixXXX) and reformatting it with a USB card reader (not quick format option) did the job.

Never had another similar problem on this F.C.


Hi guys,
Have same issues with logging :frowning_face: After update to 3.5.3 logging is almost impossible.

Did you reformat your SD card?

I have pxfmini on RBPi3 so whole my system is on SD card even log files. Therefore I can’t reformat it because it is linux image directly from Erle :frowning: