Pixhawk/APM - Unflyable/Spontaneous Movements

Hey Guys,

Long time lurker, first time poster.

I have a really weird, weird issue. It’s with a custom built Hex that I’ve had for 2.5 years and been flying on APM without an issue this whole time.

So, I will try to describe what is happening during flight. Generally speaking, there is very little total control over the Hex. I give it a bit of throttle, it goes into a very “unstable looking” hover then with spontaneously want to pitch or roll. The more input I give it on the pitch, roll and yaw, the quicker it does this. I can give it 100% throttle whilst holding the Hex on the ground and it will spin all motors hard and generate full thrust, when it is in the air it will give out a maximum of what seems like 50% power. Sometimes when it lands and I go to give it power, it just won’t take off and spins the motors at what looks like 20-30% power, even though I am giving it up to 100% throttle.

Now, that is flying in stabilise with “out of the box” tuning on both APM 2.6 and Pixhawk. When I fly Acro (with ACRO_TRAINER = 0) I get exactly the same issues.

This has 5 of us all left scratching our heads. We were flying this Hex on an APM 2.6 (normally updating firmware as available) for months without an issue, I then had a fly away whilst in Loiter that resulted in a heavy crash. We decided to tear it all down and rebuild and put a Pixhawk in, now we have these issues, no matter what we are trying.

Current Hardware:

  • Custom Hex Frame
  • T-Motor MT-3506-25 650KV
  • Pixhawk with 3.1.2
  • 40 AMP Plus ESCs with BLHeli
  • Satellite into Pixhawk & DX8
  • 3DR uBlox with Compass
  • 3DR Power Module
  • 2 x 4S 4000mah Nano-Tech Batteries
  • 13x4.7 Props

What we have tried:

  • APM 2.6 (firmware 3.1.2)
  • Pixhawk (firmware 3.1.2 then rolled back to 3.1)
  • Changed ESCs from old Multistars with SimonK to Plush 40amp with BLHeli
  • Run Pixhawk from its own Power Module instead of the power module that then goes to the distribution board and supplies power to ESCs/Motors
  • Changed from using Satellite plugged into Pixhawk & a DX8 to EzyUHF and a Taranis
  • Used 2 different GPS units
  • Removed all other hardware not needed (Vid TX/RX, Mavlink, OSD)
  • 2 different PCs running Windows 7 to load Firmware onto Flight Controllers. Cleared eeeprom before every firmware change.
  • Re-Checked every single wire and solder join. Re-soldered Distribution board

We are lost at to what might be causing this. I have uploaded 2 flight logs from the Pixhawk (transferred across from Micro SD card). I am very limited in my ability to read these, so maybe you guys can see something I can’t.

Any help would be greatly appreciated! We have a lot of hardware here, so can keep trying different combinations…which is weird, as we have changed just about every bit of hardware and am still having problems.


This is almost certainly a motor setup problem. Have you run the motors test in the CLI to check the order? I also recommend updating to 3.1.4.

Thanks jschall.

I have updated to 3.1.4. Run the motor test a few times.

You were onto something, discovered slight damage to 2 motors that seemed to have got worse. The windings were slightly damaged inside the can. Testing them on a servo tester showered up their erratic behaviour.

Terrific, I now think the problem is solved…go to fly and the Hex is still unstable (expected as it hasn’t been tuned) but when I give it more than 50% throttle, it flips and looses throttle.

I am stuck here guys, any suggestions?

Here is the flight log of the flight that just occurred…