Pixhawk and Telem2 port on Raspberry Pi


I was trying to connect my Pixhawk to a RPI in order to get MAVlink messages onboard and forward them through a WiFi or 3G link.
When connecting them as instructed, nothing seems to be transmitted over Telem2 port. Even with ser2net bound to the RPI’s serial port, APM planner won’t connect through the IP/port.
I’ve used information on this page: dev.ardupilot.com/wiki/raspberry-pi-via-mavlink/

Is there anything I should do to activate Telem2 port or is it always active and available to be connected to APM Planner?

Anyone already tried this kind of setup and could help me on this topic ?
Any help would be really appreciated, thank you !


Hi Bruno,

[quote=“brunom”]Is there anything I should do to activate Telem2 port or is it always active and available to be connected to APM Planner?[/quote]The telem 2 is always active, if you have a telemetry radio connect it to telem 2 and establish a connection to APM planner this way you can confirm the telem 2 is working.

Hi, thank you for you quick response. This what I thought, that Telem2 was always active, but receiving no data made me think about it twice.
It could be related to the RPI’s serial port then, maybe bitrate or anything else.
I don’t have a radio set yet and cannot test that I’m receiving data from this port.
Is it always sending data, even when disarmed or freshly booted?
Are just RX and TX needed, no flow control mandatory between RPI and Pixhawk ?

PS: I’ve mistakenly marked the post as solved, but it’s not, can’t find how to unflag it, sorry!

Thank again !

No flow control is required, please try changing some parameters on the Pixhawk.

SERIAL2_BAUD, 57 (telemetry output at 57600)
SR2_EXT_STAT, 2 ( 2hz for waypoints, GPS raw, fence data, current waypoint, etc)
SR2_EXTRA1, 5 ( 5hz for attitude and simulation state)
SR2_EXTRA2, 2 ( 2hz for VFR_Hud data )
SR2_EXTRA3, 3 ( 3hz for AHRS, Hardware Status, Wind )
SR2_POSITION, 2 ( 2hz for location data )
SR2_RAW_SENS, 2 ( 2hz for raw imu sensor data )
SR2_RC_CHAN, 5 ( 5hz for radio input or radio output data )

To modify these values, enable advanced view in file, connect to apm planner, go to config/tuning, full parameter list, search and modify the parameters and click write parameters.

I have tried to change sr2_extra to 20 hz via mission planner and then I run a basic script printing the attitude each 0.05 seconds, so 20 hz… but I can see 5 values being the same, so, its not being updated, so, its working at 4hz…

it appears the changes to parameters I do while on mission planner, they are never saved… is there a way to fix those parameters?