Pixhawk and LIDAR-Lite Rangefinder in AUTO mode

Hi all,

I got a LIDAR-Lite Rangefinder installed on my Copter 3.3-rc8 and it works great in Loiter and AltHold mode.
However when I try to performing an AUTO mission, Pixhawk follows the altitude from barometer instead of the LIDAR-Lite Rangefinder.
I need to perform some low altitude AUTO grid flying over a field and the barometer doesn’t hold the altitude well, LIDAR-Lite working in AUTO mode will help a lot.
I have read some of the source code of the Copter 3.3-rc8 firmware and notice that rangefinder is not enabled in AUTO mode, so I tried to modified the code but the result is not good.
So is makeing sonar enabled in AUTO mode on the Copter 3.3 developing schedule? If so when will the code released?



I have the same issue on a Copter 3.4-dev. I’m trying to use the LIDAR in Auto mode.
I would like to know if you managed to make it work on yours since your last post.


Hi, I have the same issue on my copter, have you fix this issue,and it’s very emgency?

if do, would you please give me some suggestions?

Thanks a lot