Pixhawk and ESC EMAX NANO 12A OneShot125 problem

Hi All
I need help and advice
I build small quad with pixhawk ( firmware 3.4.6) and ESC EMAX NANO 12A OneShot125.
First I have a problem with calibration. I do step by step ( http://ardupilot.org/copter/docs/esc-calibration.html) but after step 3 I get only yellow solid led ( the big one). I follow to next steps ( press sefty button) .
It’s seems to esc were calibrated. ( I heared meny beeps)
But after restart motor wont spin in the same time.
Motor 2 and 4 spin after arming but I have to incrase throttle about 20% to start motor 1 and 3.
Thaks in advance for any help and suggestion


Be carefull with 3.4 and oneshot, I had bad crash because Esc worked only till 50% of range and above 50% speed was constant.

3.5.0-rc7 should works better with oneshot125 ?

Didn’t tried yet, but I saw some fixes related to oneshot

I upgrade to 3.5-rc7 but I cant choose ESC Type … and I cant find ESC type in full parameter list…

MOT_PWM_TYPE=2 for Oneshot125. There was a specific fix in 3.5-rc7 for Oneshot125 calibration.

Now I upgrade to 3.5-rc7 and I cant find parameter MOT_PWM_TYPE… I search Full parameter list…
What I do wrong ? Any idea ?