Pixhawk and Compass Problem - Getting Out of Control in GPS Mode

Guys, I did Hexacopter with the Holybro Pixhawk 4 FMU5. Slightly big size. But when I switch to Gps mode, it tends to flip over. I understood from the log records that the problem was in Compass.
It points in the right direction on the Pixhawk’s built-in compass. When I plug in the external GPS + Compass module, it still points in the correct direction. However, it takes priority data from the Built-in Compass.

Since high current flows in the instrument (6215 340KV 6 motors) I just want to activate the external compass. When I just activate the external compass, it says Bad compass data, and points in the opposite direction. Although I set rotation = yaw to 180, nothing changes

I just plugged in another Pixhawk GPS + compass module, same issue persists. Pixhawk4 mini has the same problem with it.

I think there is a basic setting that I skipped. (If there is no hardware problem in Pixhawk!) The situation is fully understood in the pictures. Thank you from now.

Also, when I rotate the external compass, the vehicle does not respond (Pixhawk GPS+Compass)

send BIN log file for a better analysis

2020-08-31 18-18-43.bin (800 KB)
thank you for your quick return
other previous records


unfortunately i cant get any useful data from logs
but totally check motor directions and ESC connections , disable internal compass and finish tuning process instruction and also motcompass calibration may help

1 Like

Your compass is heavily impacted by motor output. It is too close to the ESC wires or to the batteries.
The normalized compass value should be constant regardless of throttle.

Since there is only two compass in the log, it means that your external compass is not detected. Exactly which gps+compass combo are you try to use ?


Thank you for your answer. Hosein Ghanbari. I can’t motcompass. because I can’t use the Pixhawk’s Fmu. 6 * 50 = 300A current. I reviewed the other things you said. . . 300

Mr. Andras Schaffer. Thank you for your answer. Under Pixhawk is Pdb. very high current. So I just activated the external compass. but I noticed that there was no Pixhawka data from him either. When I rotate the gps + compass module, it doesn’t respond at all. Bad compass gives health error. Is there any setting I don’t know to only activate the external compass? Or is the pixhawk defective?

ok so try to install external compass 30cm higher than motors

1 Like

It would be good to know, what kind of external GPS + compass combo are you using.
If it is not detected by Pixhawk, it can be a faulty wiring or a faulty compass, or a type which is not enabled by default.

1 Like

Pixhawk’s own original GPS + Compass module. I’ll upload a picture to you tomorrow

I just connected the compass of the Radiolink SE100. Sensors are also visible. However, it does not receive data from it either.

Compass Calibration screen image. I guess it doesn’t even calibrate the external compass. Currently, there are 2 external compasses in the system.

Check COMPASS_TYPEMASK it should be zero. Also put back ArduCopter instead or Rover.

I checked. The value is 0. I have installed Arducopter V4.0.3. However, nothing changed.
If there is any improvement, I have informed you.

Kakute f7 V.1.5 IMU was out of order.
Pixhawk4 mini barometer had never worked.
That’s how the Pixhawk 4 did it.
Holybro 433Mhz 500Mw telemetry module range is 1 meter. Disconnection starts at 2 meters. It doesn’t connect at all at 3 meters.
I will stay away from Holybro products from now on.
Tech support doesn’t even respond.