Pixhawk 4 running Ardupilot Gimbal setup need help

This is my first ever question here, please go easy on me if I sound stupid. I am having a bit of problem getting a 3 axis gimbal to work with Holybro Pixhawk4 running the latest version of arducopter (above 4.0). So I have managed to control a 3 axis gimbal(tarot 3d-v) and another 3axis gimbal +camera with 10x zoom (tarot peeper) successfully with a cube orange also running the latest version of arducopter. I used the sbus out of the cube to control the gimbals and they both work perfectly fine. Now coming back to the Pixhawk 4, I tried doing all the same things that I did earlier but it just doesn’t work. Tried some other permutations but no luck. I couldn’t find any literature out there which might be of help or any videos/discussions on forums.
So can anyone please tell me what am I missing here? I thing it must be a small parameter or a step that I am missing to make it work with the pixhawk 4.
The pixhawk 4 is paired with its own PDB and module (PM07). Also the sbus out on pixhawk 4 is a connector instead of the 3 pin rail like on the pixhawk 2.4.~ or cube. Have to use jumper wires to connect to the gimbal’s sbus wire.

Pixhawk4 must work as well as CubeOrange when it comes to gimbal control over SBUS.
So check your parameters and connections again.

Thanks for the reply but I did copy all the parameters and settings same as that of the cube and hoped it to work at the first go. It didn’t. :expressionless: Then I tried it with the aux channel rail with the 2 wires for tilt and pan separately as opposed to the single one for sbuso, mapped the settings and parameters accordingly. Didn’t work again. I know it must be something small that I am not doing right but its frustrating. Can you please go through the below points to see if they are correct in each case.

  1. Connecting with SBUSo

Connect the gimbal control wire to SBUS out port of pixhawk4
Change parameter brd_sbus from 0 to 1.
map rc8 to tilt and rc9 to pan in gthe gimbal control software.
In the camera gimbal setup set gimbal type to servo, Set tilt to servo10-rc8 & pan to servo 11- rc9.
Power on the copter and push the hardware safety switch.
Power the gimbal, it stabilises.
Gimbal works on CubeOrange but not on Pixhawk4. :confused:

  1. Using the Aux pins

plug the 2 wires for tilt and pan of the gimbal to AUX 1 & 2 i.e. servo 9 & servo 10 respectively.
In the camera gimbal setup choose gimbal type to servo.
Tilt- servo 9-rc8 and Pan- servo10-rc9.
power the copter and gimbal, gimbal stabilises.
gimbal works on the cube orange but not pixhawk4. :man_facepalming:

pixhawk4’s wires are connected correctly as per the manual on to the pm07 i.e IO pwm out to IO pwm in and FMU pwm out to FMU pwm in.


Facing the same issue.

Is it resolved,kindly please help to figure it.

Thanks in advance