Pixhawk 4 motor testing issue


I’m testing the motors on my quad through Mission Planner. Everything worked great when I ran the test on each motor individually (A, B, C and D), and also worked fine when I did the sequential test proceeding from the front right clockwise. However when I tried the “test all at once” option, only the front two motors turned, with the back two being completely still. . I’ve tried upping the throttle percentage from 5 to 10 but it didn’t change anything (besides the speed of the motors that were turning).

I’m running a Pixhawk 4 flashed with the latest Arducopter 3.6.3, and have set up the ESCs to use Dshot120, so they’re running off of the first four AUX (FMU) outputs, ie SERVO9 through to SERVO12 functions.

My ESCs are Spedix 35A BlHeli_32. I’ve configured them using the BlHeli_32 suite, and set all the PWM mins and maxes to 1100 and 1900 respectively (in both the ESC and the flight controller firmware). This is what I was advised to do, rather than using the auto-calibration in Mission Planner or QGroundControl to set the PWM range.

I really can’t figure out why testing the motors all at once wouldn’t work, when they all work individually. I know that there’s not a lot to go on with the Pixhawk 4 at this stage, especially with Arducopter, but any help, suggestions or advice would be very much appreciated.

Thanks a lot,