Pixhawk 4 Mini - Suspected only one IMU working

I’ve just installed the latest stable version of arduplane on a Pixhawk 4 Mini and it only seems to be detecting one IMU. I’m not sure of the proper way to check if its using two IMU’s but there is only data from a single RAW_IMU being logged. I have tried to set EK3_IMU_MASK = 3 and on reboot this resets itself to 1.

Is this a known issue with the Pixhawk 4 mini or more likely a configuration issue on my end? Is there a better way to test which IMU’s are being used?

In Mission Planner Setup>Mandatory hardware>HW ID
How many does it show?

Hi Dave, unfortunately I cannot get mission planner to connect to my FC - I’m running windows on an M1 Mac so I guess that is the problem.

I did however connect with MAVProxy and ran the command devid. This gave the following output:

BARO1_DEVID: bus_type:SPI(2) bus:4 address:1(0x1) devtype:11(0xb) BARO_MS5611 (721186)
COMPASS_DEV_ID: bus_type:I2C(1) bus:0 address:14(0xe) devtype:10(0xa) IST8310 (658945)
COMPASS_PRIO1_ID: bus_type:I2C(1) bus:0 address:14(0xe) devtype:10(0xa) IST8310 (658945)
INS_GYR_ID: bus_type:SPI(2) bus:1 address:1(0x1) devtype:40(0x28) INS_ICM20689 (2621706)
INS_ACC_ID: bus_type:SPI(2) bus:1 address:1(0x1) devtype:40(0x28) INS_ICM20689 (2621706)

Would this suggest that the second IMU is not being used?

These are the sensors that should be detected:


So it looks like you are missing the BMI055 Accel/Gyro.

I seem to have resolved this now. When booting I was getting the error ‘MSG4525[0] No sensor found’, which is an airspeed sensor I do not have fitted. Once I disabled the airspeed sensor in the settings I am now getting the second IMU listed when running devid.

Thanks for the help.

1 Like

Actually, maybe I spoke too soon on that. The second IMU is no longer listing in devid. Any ideas on what else I can do to troubleshoot this? I flashed the FC with PX4 and data for a second IMU was in the logs so I’m pretty sure its not a hardware problem.

Maybe a firmware mismatch?

Try the firmware loaded here (if you haven’t already): ArduPilot firmware : /Plane/stable/PH4-mini

I already tried reloading the latest stable firmware. I’ll see if any of the older versions are working.

Did you download the .apj file from that link and use Mission Planners “load custom firmware” to flash it?

I downloaded the apj and flashed it with QGroundControl - I can’t seem to get Mission Planner to work on my M1 Mac.

OK, same thing.

Ok, actually got it working this time. I loaded the arducopter firmware and then back to the arduplane firmware in an attempt to properly wipe the firmware and now the second IMU is showing…weird. Thanks again for all the suggestions guys!