Pixhawk 4 Mini: Check BRD_TYPE: INS: unable to initialise driver

Hi all,

After flashing ArduPlane 3.9.3 onto a new PH4Mini unti and having it successfully boot a few times, I started getting the “Check BRD_TYPE: INS: unable to initialise driver” error. I should note that PH4Mini’s IMU is on a separate little board connected to the main board via a fine ribbon cable. On my other PH4Mini, I had this issue from the start, and on inspecting the cable found it to be cracked. However, on PH4Mini, the cable looks intact, and again – it worked fine for a few boots. The drone was sitting on my desk throughout these boots though, and the motors and even servos were off, so there were no vibrations that could cause an extremely tiny crack to develop.

So, what are some ways to get rid of this error, assuming it’s not a hardware issue?

And if it is a hardware issue, how do I ascertain that?



Kindly check this parameter INS_IMU_MASK

It should be set to 7.

I also had issue Check BRD_Type, failed to update IO firmware. Using ChibiOS and Copter 3.6.10. I tried using PX4 and it works fine with that OS and Q Ground control. So I reloaded againwith MP and chose board type PH4, and that seemed to do the trick.

How do you select BRD_TYPE: PH4? I see no button for this. Only PH2.1 or PH. I try MP and QGC.

Is there anyone who can show us how to define a new type under BRD_TYPE: PH4Mini? I miss this special choice-button for PH4-mini.