PixHawk 4 Mini Boot Problem


I have a HolyBro PixHawk 4 Mini installed into my old Mariner/SplashDrone.
Both a Minim OSD and a HC-06 Bluetooth module are connected to the Telem1 port in parallel, except for the PixHawk RX pin, which is only connected to the HC-06 TX pin.
Both Minim OSD and HC-06 board get their 5V supply from a seperate BEC instead out of the PixHawk, to avoid overloading the thin power wires between PixHawk and power board, especiually as the power board delivers only about 4.9 instead of 5V or even a bit more.

This worked until yesterday, when the PixHawk suddenly refused to boot after battery change.

When I removed the PixHawk from the copter and powered it via USB it run normally, so I connected more and more peripherals and found out that it refuses to boot as soon as I connected the HC-06 bluetooth module again.

Meanwhile I found out that the Bluetooth module seems to have a bad TX port, by connecting it to an FTDI adapter and trying to go into command mode. It must have died during the last flight.

But now my question to the experts here, how can bad incoming data from the Telem1 port prevent the PixHawk from booting? It seems that the HC-06 TX port outputs only few millivolts without a signal.

I don’t have an answer to your question but a comment. I replaced the BT radios I was using with ESP8266 WiFi radios and found it to be a more stable protocol and easier to implement. Just a suggestion. I have them on a Plane, Multirotors and a Rover.

The BT-06 module worked perfectly after correct setup until this hw failure. Before, I also thought about what link to use, either a dedicated 450MHz data link, Bluetooth or Wifi. But as the r/c system uses 2.4 GHz I didn’t want to place a strong Wifi transmitter near to the receiver. Using a 450 MHz data link was no option, as I don’t have much space within the Mariner for placing the big antenna reqauired.
And I am confident with being able to use QGroundControl wirelessly for flight preparation and can live with the limited range, so I decided for Bluetooth.

Hi Gerd,

From the beginning I have that ESP8285 DT-06 WiFi-Module in my sailplane and it’s possible to fly out of sight with absolutely no failsafe-reaction. So no danger.


Indeed. I use the WiFi radios with 2.4Ghz RC with no problem. I tested this extensively with and w/o the radio active on multiple craft. QGC, Mission Planner, Android, IOS or Windows it just works.

I remember a test flight with a copter equipped with Jeti receiver and GoPro Hero 3 BE+. As the vtx was not installed yet I activated the Wifi function on the GoPro. That caused a dramatic reduction of r/c range to about 100m instead of about 2 km.
Since there I am cautious with Wifi components on my copters.

Tomorrow I will get two HC-06 modules, one as spare. And as I found a cheap European source for the DT-06 I also ordered two for testing.

But back to my original question, is there no ArduCopter developer available here who can tell me about the boot problem?

Hi @Quaxwilly,

Today I got two of these Wifi modules and tried them out.
I have reduced Serial Split Timeout to 30ms as was proposed at various forums, but still connection to QGroundControl is a bit unstable and parameter list loading takes more time than with the HC-06 Bluetooth module.
Also I wondered about getting two different boards, where the pins on one board are just inverted compared to the other one. But both seem to work so far…
What are your settings?

Regards, Gerd

Hi Gerd

My settings are 57600 Baud, 8, None, 1, 30ms - just as recommended in different forums.
I couldn’t detect any unstability so far. But maybe it’s an effect of the PixHawk - I’m using just Matek-450-wing FCs.

Cheers, Willy

Hi @Quaxwilly,

I have the same parameters, just found 40ms more reliable. Sometimes QGroundControl (Android) has problems with loading all parameters.
Have 3D-printed casings for my modules and will test them in flight.

Regards, Gerd