Pixhawk 4 incompatible?

I tried to install APM:Copter V3.7.7 Octa on the Pixhawk 4 and I get:

ERROR: Firmware not suitable for this board

I tried to load Rover to a Pixhawk4 … ERROR404


And other issues …

Pixhawk 4 is very new, its not supported on the stable release, you will have to use a beta firmware

That’s great. But why can I install arduplane without any problems? (not the beta release…)

because the current stable release of arduplane came out a few weeks ago so is more upto date than copter, the next stable copter should be coming out in the next month or two

OK. I’m trying to make sense of this. Pixhawk 4 is a supported hardware platform by Ardupilot.

Arduplane supports pixhawk 4. Arducopter doesn’t, and I’m suppose to install a beta version (untested and at my own risk) to get it to work on a Octa Copter.

So how can ardupilot (which is the leading organisation I guess) support a hardware platform which is not supported by the individual platforms?

In my understanding, pixhawk 4 is just another PX4 platform. So PX4 isn’t compatible with PX4??

Maybe I’m don’t understand everything, but it’s getting real confusing now…

Yes, but is very new

Arduplane stable supports it, arducopter stable doesn’t yet, all firmware support it in master. You are welcom to wait for it to be in stable realese before you install it

it supported on master by all,

PX4 is software and is separate to Ardupilot


As @iampete said the support for the pixhawk4 is not complete yet, so you have to use beta release for copter.

@Fishton, same as for copter, only beta release will have the pixhawk4 as it need ChibiOs support.

1 Like

Seeing that I am using it on a boat, I’m thinking plane should work, is this possible as all I need is throttle and rudder?

There is not a current rover beta, you will have to use master, http://firmware.ardupilot.org/Rover/latest/Pixhawk4/

1 Like

I myself have been struggling with installing and setting up the Pixhawk4 with Arducopter. I can get the beta version to install, and at first everything seems stable, but then I start having parameter corruption issues.

These parameter corruption issues range from wacky/random values showing up, to parameters not being saved. After buggering around with it for a week I’ve decided to install PX4 v1.8 until Arducopter gets its issues sorted.

Followed your advice. Guess what:

Error uploading firmware
ERROR: Firmware not suitable for this board

I tried Arducopter V3. 6.0-rc10 Octa

My problem is this:

Pixhawk 2.1 (the cube) has a problem with telemetry 1 and 2. The rx and tx seem to be not capable of driving some devices. When I connect rfd900, it works, but another device doesn’t.

I tried an older pixhawk (pixhawk mini) and I tried pixhawk 4, both work fine on any device that is connected. Only pixhawk 2.1 has this interface problem.

So I would really like to use the pixhawk 4, but I’m super stuck in getting anything else but arduplane on the device.

hum, try updating to the beta release of mission planner, support for these board is still very new

1 Like

I would like to clarify
Pixhawk 4 is a trademark that Holybro purchased. It doesn’t relate to Pixhawk, its not the 4th version. the good devices are now moving away from the terminology “Pixhawk” eg the Cube which was a Pixhawk 2.
PX4 is the hardware standard that they are using and which can run Ardupilot. In the end, the quality doesn’t relate to the Pixhawk name. A good example is the IMU vibration isolation in a Pixhawk 4 is just a foam pad that the IMU is mounted on. Thats not a real isolation method…think of the Jello effect on a camera that has been mounted on a foam block. Its pretty cheap.

David K
UAV Engineer/Aerosmith

1 Like