Servers by jDrones

Pixhawk 4 - Copter about to flip forward - RC problem?

Hi,

truly new to the hobby. This morning I have tried to takeoff in stabilized mode but the quad looked like it wanted to flip forward.
All calibration done. ESC synced before flight just in case.

Looking at the log
something doesn’t look quite right but I’m not sure how it should be.
Just in case here is my params list.

Thanks,
Gal

If you are truly new to the hobby you should not be running a beta release of the firmware.
Get your copter flying with a stable release before venturing into release candidate firmware.


There is why it wants to flip.
There is no RCout on Motor3???
Does motor3 spin at all?
Have you bench tested this quad with the props off?
Arming, RC stick input and motors rev accordingly? Roll? Pitch?
Armed and throttle at 1/4, tilt quad, do low motors speed up, high motors slow down?
You also have NO battery sensor readings?
Have you calibrated compasses? Accelerometers? ESC’s?
How carefully have you been through the Wiki?

Currently, it’s the only way to have the PixHawk4 flying with ArduPilot. And IMHO works much better that 3.5.x …:smile:

Hi @mboland and thank you for your response.

As mentioned by @luisvale it is the only way to use ArduCopter on Pixhawk 4 (FMU_V5).

Regrettably, I don’t know what is RCOut on motor 3. Is that the signal that goes from Pixhawk to motor 3?

To your other questions:
All motors calibrated numerous times and also before flight on the field.
Al motors tested on bench and are operational A,B,C,D (1,4,2,3) and also in sequence and together.
Disabled PreArm checks and radio (X9D) arms and fires up all motors as it should.
Reversed channel 2 - pitch (ele) on radio (-100 instead of 100)
Also did the test where I hold the quad, motors seems to try to balance.
Battery sensor I believe is a problem with the FW, however I do get a reading on my OSD.
I have been reading Wikis and Youtube for the last two month, I have taken my quad apart more times that I wanted. This Holybro Pixhawk 4 gave me so much grief and I still do not know what is the reason for RCOut 3 at 1000.
I did flew this quad once with the same hardware with Matek f405 CTR FC, but it lacks so many thing that I want which exists in ArduPilot.

Could you please explain to me, what is missing and what might be the reason for that?
Is it possible that my FC is faulty?

Best Regards,
Gal

Thanks @luisvale, I didn’t notice he was running PixHawk4.
And I must agree, 3.6 is flying very well on all the machines I have been testing it on.
Love the new Loiter.

First off, this is only the .tlog with these values.
A .bin file with the RCin and RCout values logged would be preferred.
When you say All motors calibrated numerous times and also before flight on the field.
What are referring to? Do you mean you calibrated the ESC’s at the field?
As the motors run when doing the motor test it doesn’t seem the PixHawk has a faulty output.

The only other thing I can think of is that you are being too cautious in your attempt to take off.
It can be a bit daunting for the first flight, but even the big octo’s will tip on their very first lift off.
You need to arm then ‘jump’ the copter into the air.
Not too hard, just aim for a metre high to get it out of ground effect.

To play it safe, when on first lift off and the copter wants to tip, say forward, I will back off and then raise the throttle again with some back elevator added.
Usually the copter will want to tip backwards then.
So I know the controls are working in the correct sense.
I usually check the roll that way as well.
When I am happy that I have control I will give the throttle just enough to get it light on its feet, then a little ‘punch’ to clear the ground quickly to a metre high.

ok, so, from the beginning

What kind of ESC’s do you have? on the parameters are defined as normal PWM type.

Set the MOT_PWM_MIN to 1000 and MOT_PWM_MAX to 2000 and calibrate the ESC’s

https://plot.dron.ee/Avku

Also a series of minor issues

04:48:30 16 2 EKF CHECK: EKF CHECK BAD VARIANCE
04:48:30 17 1 EKFINAV FAILSAFE: OCCURED OR FAILED TO INITILIASE
04:48:36 17 0 EKFINAV FAILSAFE: ERROR RESOLVED/CLEARED
04:49:58 2 2 RADIO: RADIO LATE FRAME

more to follow :slight_smile:

Yes, when first the copter looked like its going to flip I did the ESC calibration sequence after I took off the props at the field just to be on the safe side.

Actually, cautious is my middle name :slight_smile: so maybe I do play it too safe.

I shall try your advice tomorrow if its not too windy.

Thank you so much for taking the time.

and just to be sure…Are your motors plugged in the correct sequence ??

the front right motor (3) signal does not go above 1135 pwm out

ok, so some data:
frame X IronMan F650
ESC Hobby Wing pro 50A
Motors: Tarot 320kv 6s
Battery: 6S 16000mah 25c/35c
Total weight: 3250g
Props: 17"
radio X9D
receiver: X8R

I believe the errors shown in the log are from the boot sequence after connecting the battery and turning the radio afterwards, does it make sense?

I shall set the MOT_PWN_MIN to 1000 and the MOT_PWN_MAX to 2000 and re-calibrate the ESCs.

I shall try to do a flight tomorrow morning, its summer here and the winds picks up here early to about 15-25mph.

Thanks for all your help,
Gal

So, I went out this morning, 0 wind.

I have tried to do a small lipp, however, my quad almost flipped.

When I tried to fly in Stabilezed, the quad tries to flip again. Motor 3 clearly slower than the others.

Here is the log bin.

Thank you,
Gal

P.S. @luisvale I have tried setting MOT_PWM_MIN /MAX, however Pixhawk and my ESCs don’t like the values - Pixhawk is in error and escs are beeping fast - so I left it at 0. UPDATE, it accepted the values and it servos output in MP does seem better. I shall try it this evening again.

after you set those parameters, run the esc calibration

@luisvale and @mboland we have a liftoff yesss!.

Had a wonderful 3 minutes± flight with takeoff without any indications to flipping and a terrible landing :slight_smile: but no damage.

Thank you both so very much for all your advice and great input !!!

Now I can get into learning how to fly it.

Thanks again,
Gal

Servers by jDrones