Pixhawk 3.1.4 rc1: crazy HUD on MP 1.3.1 after CompassMot

Yesterday I had my okto with Pixhawk well tacked on the floor, for motorsync test, dynamic calibration etc… firmware is 3.1.4 rc1, Mission Planner 1.3.1. I had already done all the calibrations successfully
I wanted to try “compassmot” from CLI.
this is result (BAD - all values are “NAN” - I have also configured correctly 3DR power module)

I repeated compassmot with same result:
After compassmot , I began to see strange things on Mission Planner HUD’s, (values mx-my-mz compass was “ZERO”, accellerometer and altitude was very crazy)
I tried, reboot PC, reboot Pixhawk more times, powering Pixhawk with only USB, the result is always the same you can see in the video.

I tried to test from CLI: baro (altitude is right here while on HUD was very crazy)

and compass (there was values here, on HUD/status mx-my-mz was “ZERO”)

I would like to reset everything and re-istall firmware, but first I would like some advice from comunity.
Might be some bug between 3.1.4r c1, Mission Planner 1.3.1 and compassmot ?

Ciao - Giuseppe

[wf]Pixhawk hardware[/wf]

Release candidates are primarily for developers and pro users who want to help the developers test the code. Normal users should stay away from them. You should also read the release notes before trying to fly an unstable version! The compassmot-NAN-issue is a known bug!

ops, I 'm wrong, I performed 3.1.4 (not RC1)
Thanks Stefan, I just deepened that this is a known bug.

Ciao - Giuseppe

here my first compassmot on Pixhawk with 3.1.5 rc1

Ciao - Giuseppe