Pixhawk 3.1.4 'deadcat' quad crash - log + vid


Been flying this quad for a few months without issue, recently upgraded to 3.1.4 and today had a crash. A couple broken plastic legs but otherwise no issues. I checked the logs for what I could understand and I did not see any power, vibration or mechanical issues… hopefully one of you guys can point me in the right direction.
-Pixhawk running arducopter 3.1.4.
-GPS with external mag
-3DR 850kv motors, 10" props
-20amp AfroESC’s
-Frame= “Xugong”.

Issues began when I switched to loiter. It’s hard to tell in the video (gimbal), but it’s clear in the logs; after I switch to loiter there are some erratic maneuvers, then it seems to be ok… I start to yaw while in loiter and it falls to the ground.

Flew 5 batteries earlier in the day without problem, using loiter without issue. Only difference when the crash occurred is the wind was blowing a bit harder.

Attached logs and here’s a vid:

Any help would be greatly appreciated - thank you in advanced!

you probably had mechanical failure on motors 2 (lock at rcout log) or issue sync on esc nr. 2
Motor 2 is to the left and your quad tipped to the left.
You was alredy on Loiter when happened, didn’t happened when switch to loiter.

You need to check motor2 and esc nr. 2.
Do you have ground of pwm signal connected ?
Try it Motyorsync to test potential issue sync with your esc’s

Ciao - Giuseppe


Thank you for taking the time and looking at this for me.

Today I tried first replacing the ESC for motor #2; when I armed the copter, #2 motor twiched for a sec then went on. I tried to hover but the copter leaned back hard, so I countered slightly and tried to land… it started to drift, so I countered more then the copter flipped to the ground.

Now i replace #2 motor. Tried another flight and same exact behavior; copter wants to drift backwards, I counter… any hard movement causes the quad to flip.

I calibrated the accel both times; on level ground the HUD shows level. Also tried AC 3.2rc2 and same behavior. I’m really stumped :frowning:. attached logs. I can say that motor #2 felt warmer than the rest (both the old & brand new motor). what could be going on here?

Perhaps you haven’t redone the ESC calibration?
copter.ardupilot.com/wiki/initia … esc-motor/

I wish it could be that easy - I redid the calibration after installing the new ESC - I re flashed all ESCs with latest simonk firmware (mostly because I was not sure what version the other 3 had and wanted to make are they are all the same)

thank you ,though - appreciate any help I can get