Pixhawk 2 Rover No GPS/No Radio

I have failed to make my Pixhawk 1 work as a rover so I installed a standard Pixhawk 2. Upon loading latest stable Rover I get no GPS (although I can calibrate to green) and I get no response from bound radio (Taranis Plus with X8R) The sonor (Maxbotic I2c) works and with some adjustments the FAILSAFE voltage shows up. Do I have a bad unit or am I missing something?

I have fixed the radio calibration but arming does not make anything turn or roll. My GPS calibrates but the HUD still shows NO GPS. Now the Maxbotic I2c is NOT working. I have installed with and without ChibiOS.


Maybe it’s in HOLD mode? Try it in manual and maybe that will work. also if there’s a safety switch that needs to be pressed, or it can be disabled by setting BRD_SAFETENABLE = 0.

I was in MANUAL. I have had trouble with PH1 and PH2 with this rover. I am building a T800 tracked robot with the same Pixhawk 2. I will get back to you on this. Strange to have NO GPS. Thank you for your reply.


Still no luck with Skid Steer version. No GPS. The RADIO shows good calibration but no movement on SERVO OUTPUT. Onboard MAG calibration is good but COMPASS_OFS_Y = -322744 and COMPASS_OFS_Z = -360.6332 which (from your video) is horrible. Not a COMPASS health issue, just GPS: No GPS. I can get one side of a motor test to work but it does not stop. This may be due to a ESC calibration issue. I will make a video to show the issue. This is very frustrating since it is both PH1 and PH2. Could it be bad input from Taranis Plus?


Maybe provide a dataflash log file?

Here it is…


I’m afraid that tlog (telemetry log) was pretty much empty. It’s actually a “dataflash” log that works best. Try setting LOG_DISARMED = 1 and reboot, do some tests and then download the log as described here on the wiki.

Ok. I thought it might be a bust. I have the PH1 working on the Turnigy Trooper frame but I see no options on CH 7 for tuning. I will get you a DFL asap. Send me a bill… :wink:

Ok. This should be a good test. There is a photo of the guts in the folder too. I might have to use two sets of motor controllers instead of ESC’s? This rolled fine from the X8R.

It looks like the MOT_PWM_TYPE is set to “3” which is for “brushed with relay” but I think from the picture the ESCs accept a “normal” PWM input in the range of 1000 ~ 2000… they are ESCs for brushed motors but the input is a normal PWM signal… so I think MOT_PWM_TYPE should be restored to it’s default value of “0”.

That solved the motor (track) issue. This also solved the CH7 Opt on both units. The channel 7 learning options reappeared once the “normal” esc option was selected. Good to know. Thx!

1 Like


great! It’s very odd that the ch7-option drop-down also reappeared. It definitely should not be related to which motor type was selected… it’s possible but it would definitely be an odd Mission Planner issue I think rather than a flight code issue.

Maybe it’s a PWM issue? I am still baffled at the GPS: No GPS issue. I could try taking the GPS selection out of AUTO. The HERE+ GPS is a UBlox, I think, but I will have to look. Only happens when flashing ROVER.


Yes, the Here+ is a Ublox so you could try setting GPS_TYPE to “2”.

If the GPS was configured to output NMEA messages that could explain why it works on Copter and not Rover. It’s not a difference in the frame but rather the age of the software. We changed our GPS driver a few months ago so that it doesn’t automatically recognise NMEA GPSs because 90% of the time, the user was using a UBlox GPS that was incorrectly configured to output NMEA. The Ublox provides better info when it’s using the UBlox protocol…

No luck with the Here+ with your settings suggestion. I have purchased mRo GPS u-Blox Neo-M8N Dual Compass LIS3MDL+ IST8310 and will see what comes of that. Update when applied. Thank you again!

Here is the LOG from the aforementioned change in GPS. GPS is recognised, but HDOP of 655.55 and no GPS lock.