Pixhawk 2 GPS Constellation useage

General question about GPS constellation utilization with the 2.1 cube and Mission Planner.

I am running a Here + RTK GPS, with the pix hawk cube and newest version of mission planner.
If I change the setting GPS_GNSS_MODE to anything other than “0” is there a way to determine whether the GPS is actually using ONLY those constellations that I select?

Basically, how do I monitor what constellations the GPS is referencing? or does the Pixhawk just filter out those other constellations when I change the GPS MODE setting?

I did a very brief test yesterday in which I switched my GPS_GNSS_MODE setting from 0 to Beidou +SBAS (iirc) and then restarted the drone, and I went from 3 satellites indoors to 0 sats, which is what I wanted (some kind of visible satellite change)

But I need a way to actually see what constellations are being utilized at any given time if it’s possible.

Any info is appreciated!

It’s not “filtered out”. The Flight Controller sends configuration commands to the GPS on boot. At least with default parameters it does. So the module is configured for whatever settings you have used. No way to tell which constellations are reporting the Sat count from Ardupilot.

Okay so the pixhawk does tell the GPS which constellations to use, is there any way you know of to verify that those constellations are indeed the only ones being used? I just need some way to verify it, when I switch between constellations… if at all possible. I’m wondering maybe if I hook the GPS up to my laptop and use U-center if that will verify which constellations it’s referencing. I don’t need to monitor the constellations constantly, I just need to be able to visually verify that whatever constellation I selected is the one being utilized.

Boot the board and from Mission Planners Ctrl-F menu select MavSERIAL Pass. Then start U-Center and connect to the Receiver (Network tpc-localhost:500) . Then from the Configuration View >GNSS Config see what’s enabled. I think it will display what’s currently configured but make a change to the GPS_GNSS_MODE parameter, reset and see if it tracks in U-center to be sure.

1 Like

So I did that on your recommendation, I was able to get connected to the GPS using U-center and the localhost connection, but nothing comes up in the GNSS window when I open it up, it’s just blank. Attaching a screenshot here for you if you don’t mind taking a look and if you have any other ideas. It says I don’t currently have a Fix so I wonder if that could potentially be the issue as to why it isn’t showing a constellation being used, but I’m unsure.


I walked thru the steps and it seems to work. And it does identify what’s configured:

But after the previous walk-thru when I was writing the post it did not connect a 2nd time. I restarted the PC and it was back to working. A lame way to address a problem I know but it worked.

1 Like

Hmm, that’s odd. So I can select the “configure” boxes in the GNSS view but it doesn’t say which ones are already enabled or their channels, like in the screen shot I posted, it just shows everything as blank and the configure boxes are left unchecked.

Try updating to the latest U-center version (not U-center 2). Doubtful this will help but I just noticed I’m using a later version than you are.

I tried it with 2 different sets of hardware. A Pixracer with a generic M8N and a Kakute F7 Mini with a Matek M8Q and they both worked. What FC and what module do you have?

So I did try to install a newer version and it always gives me an error after the install, it says something like “the code execution cannot proceed because MSVCR120.dll was not found, reinstalling the program may fix this problem”
I’ve reinstalled several times with several different versions with no luck, the version I’m on currently (19.02 I think) is the only one that works for whatever reason.

I’ll have to try and troubleshoot that today and see if I can get it upgraded, maybe it’s the issue.

Yea, maybe. Did you uninstall 1st before a new install?

Yeah I did. One of the errors that I looked up says it’s because I need to have visual studio installed, I’m gonna try that first and see if it fixes any of these issues.

Okay so I got U-center v22.02 working finally, got connected to the GPS again through the network connection tab on host 500… But still nothing is configured when I look at the GNSS config screen. Everything is still the same as it was in the last screenshot where none of the “configure” boxes are checked… if I check one, it allows me to click the enable box and then opens up the channel min and max boxes, but they don’t autofill with anything… I have to manually input that info.

Not real sure where to go from here!
Are you using a Here + GPS or are you using a different puck?

I’m not sure why mine isn’t populating.

I tried 2 different modules as noted above. Hold on, I have a Here GPS (not a Plus) on the Rover I’ll check that.

Well it works too… Is yours on a Serial port or CAN?

1 Like

My GPS was set to CAN, I changed it to Serial and was able to connect to it using U-center and then the config screen popped up and it did finally show me which constellations were configured or enabled. The only issue I’m having now is that I can’t get the Active Constellation data to show up when I open it. If I plug in an mRo F9 GPS, the constellation data shows up when I open it.

I can’t either from passthru. I actually don’t use U-center for anything but thought it would be useful to answer your question about enabled constellations.

1 Like

That’s okay, I appreciate your help. I did try plugging the GPS directly into the laptop with the included adapter cable, but it still didn’t show the active constellations when I opened the window. I’ll have to continue playing with it and see what I can come up with.