Servers by jDrones

Pixhawk 2 external RGB Led and Micro USB


(zhangpeng) #1

Sorry, the background of the photo some chaos!
But the success of the external RGB Led and Micro USB interface connected to the Pixhawk 2 above it!


Pixhawk 2.1 External Module Issues
(Gwang-Hoon Kwark) #2

Hi, I want external LED for pixhawk 2.1, so I tried connect i2c pin of external LED to i2c2 port as yours.


It worked without GPS1 port which was not connected to HERE GPS which also has RGB LED.

But It doesn’t work with GPS1 port which was connected to HERE GPS, whose RGB LED is On!

This is similar as external LED for Pixhawk 1, when external LED is connect to pixhawk1 i2c, the LED of pixhawk body isn’t on.
Maybe the priority of LED of HERE GPS is higher than external LED.
I think that External LED is very important for safe flight.
How about you, you have no problem with HERE GPS? If you have, did you solve the problem?


(zhangpeng) #3

I have not connected the Here GPS to Pixhawk 2.1. However, after the external Led is connected, it is indeed the Led of the main FC that is not lit. It is like this!


(Gwang-Hoon Kwark) #4

Then which kind of GPS did you use?
When using GPS, did you use GPS2 port?
The reason why I ask upper question is that i2c interfaces in GPS1, GPS2 might be an issue.

Please someone help me to solve external LED even with HERE GPS which also has RGB LED.

By the way I know that the pixhawk 2.1 mainbody itself don’t have RGB LED, right?


(zhangpeng) #5

the pixhawk 2.1 mainbody itself don’t have RGB LED

I use CUAV’s M8N GPS, the interface is universal. GPS2 jack I have not used it, the state does not understand!


(ChiangKaishek) #6

Long time no see Zhang sir Guess who I am?

572439391


(zhangpeng) #7

The winter is long,and xia jiba busy ~


(ChiangKaishek) #8

I asked the current firmware only supports one external LED

Need to disconnect the LED cable on the GPS

your QQ?


(Gwang-Hoon Kwark) #9

Currently The External LED in HERE GPS is controlled via i2c which also might be used for compass sensor in GPS. So, disconnecting i2c is not good solution. I think this should be consideted in firmware.


(Brendan Franklin) #10

Can someone please push this to be sorted out in the firmware I’ve been having this issue for over a year and it seems fairly simple to me


(Felix) #11

@brendanf : I updated to Copter 3.6.2-rc3 and it’s working now. I also switched from NuttX to ChibiOS, so I’m not sure, what caused it. Is yours working?


(Brendan Franklin) #12

oh awesome mate! I haven’t had a chance to get back to it lately but my try and upgrade it next weekend, that’s really good to hear I hope I have the same results!

Then it’s just the mavlink issue I need to sort for my OSD and transmitter LCD and I’m pretty much good to go for a maiden flight I think!

Thanks heaps for letting me know your a champion!


(Felix) #13

Oh no, I didn’t do anything. You have to thank the developers who made this awesome flight control software work…

Yes, please tell me if the update solved your problem. Do you know what it’s all about with NuttX and ChibiOS? (I had to look that up but actually it’s absolutely easy and you’re asked to decide which one to install after you selected the correct firmware.)

Oh and of course I’ll keep my fingers crossed for your maiden flight! :slight_smile: