Pixhawk 2 (Cube) with Here GPS failing onboard compass calibration

I am trying to do an onboard compass calibration with a Pixhawk 2 with Here GPS and compass #3 would constantly fail the process. The bars for #1 and #2 would complete and signal a successful calibration but #3 would reach full bar and then reset itself and I have to go through the whole process again for #3. I have tried letting the unit be powered for 20 mins before calibration and have also used a relaxed option both gives the same results. I can just use 2 compass to fly but it’s a waste when I have 3 of them on the unit.


I had some issues calibration my compass too on the weekend - what worked in the end was using the most relaxed fit setting available - all others - had the same behaviour as you describe. Have you tried all the options for relaxation?


Did you let the imu warm up? Latest Mp beta?
What firmware?
Mine worked with rc7

@Christian Tried it with relaxed fit when I failed it a couple of times and still didn’t work.

Could you try it after setting the “Fitness” to “Very Relaxed”? Surely that will work. If not, the final choice is just to disable the last compass. It’s actually very unlikely that it would ever be used in any case.