Pixhawk 2.4.8 Unrecognized

Hello, I recently received a new pixhawk 2.4.8 for my build and yesterday I plugged the device into my PC for the first time, trying to update the firmware. Out of the gate I noticed the PC didnt even do its usual hardware found thumps so figured maybe upon starting it until booted up but nothing happened. The larger light appeared yellow at first , flashing then went full red, back to a yellowish color then back red, then went out. I have a solid amber B/E indicator on the right side along with a flashing blue light, nothing else. It seems bricked in some regard, I have tried both Windows PC’s and my Mac with Mission Planner and QGroundControl but nothing sees it. I pulled the SD card and its blank, not sure what else to try. Ideas?

does it make the proper boot noise when it powers up?

have you made sure you’re not using a usb power cable instead of a usb data cable?

what colour/sequence is the MAIN big LED

im asking about the cable as ive got loads of them and i do this all the time.

First let me thank you for taking the time to read and answer my question. The very first time I plugged in the pixhawk, the main light flashed quickly white a few times, then went solid red, and then out, no beeps or anything and what was left were both power lights coming on and the ACT light blinking blue. I have tried about 6 different cables, a powered USB hub, multiple PC’s and a Mac. All that happens when plugged in both the power lights come on green, the right side B/E is solid orange and ACT , flashing blue and with the switch connected, it rapidly flashes red. There is a youtube video with the exact same conditions, and their outcome was a hardware failure and others saying its the cheap voltage chips being used in low quality pixhawks being produced. https://www.youtube.com/watch?v=Ewj71yqcAMw

Oh sorry aside from the main led coming on then going red the very first time, it has never came back on. And I have tested a few devices like mobile phones to make sure the phone comes on and mounts its SD card. The pixhawk never once has caused the PC to go thru its discovery/ installation thumps when plugged in, not recognized as well.

these new 2.4.8 ones do seem like they were made by the lowest bidder :confused: thats the bad thing about open source i suppose… its pot luck on quality.

mine displayed the similar symptoms to yours, at the moment it appears to be working fine (im not overly worried as its in a ground rover so im not going to loose it)

i have a dim red light on power up then after that every things normal apart from a dim red light on. in the background between flashes. i get good GPS signal and lock, it arms and drives and follows routes fine.

to get it to boot eventually, as when i first fired it up i had a bright red ERROR led, had to install an older flash from MP though AR3.2.1. iirc… i also use a separate power supply into the units power socket, have you tried booting with external power and an older flash?

i would be very interested to see if this dim red on boot was a fault or a ‘feature’ of the flash im on. i have a couple of new units on the way and ill tell you if they perform the same.

when i reflashed i did so without the card in btw, then i put it back in and lo and behold i connected straight up in MP.

good luck.

just so you have an idea of how mine is performing at the moment i hade you a quick vid of it stripped back to barebones (as im doing some work on the rover body itself in for form of a new esc etc) also ive recently re-flashed to current, but as i say to get it running in the beginning i had to flash to a significantly older version.

you can see the red light i have there on boot, which afaik means error. I may well flash back down as i am getting ALOT of sik radio problems now :confused:

Senior moment…:wink:

hello bigfinger … i have exactly the same behavior as yours (the dim red) i hope it is just a feature but the thing is when you power the card only using the usb …there is no dim red … it is present only when using the battery