Servers by jDrones

Pixhawk 2.4.8 showing mRoX21 in device manager USB

I can no longer connect with my Pixhawk 2.4.8 with Mission Planner or QGroundControl. Some how the Pixhawk is seen as mRoX21 when I look at the USB devices in Device manager. This occurred while trying to update the firmware and I must have selected the wrong choice. I have tried resetting the flight controller and the other rest button on the other side by pressing the button with power on, power off, and when attaching the USB cable and reformatting the micro SD. When I plug in the Pixhawk Windows gives the usual connection sound, the Pixhawk gives the usual power up sound, the switch button light blinks three times and the main LED on the Pixhawk blinks green twice continuously. Nothing else is connected to the Pixhawk but the switch button and buzzer. I am lost and nay suggestions would be appreciated. I am new at this so I don’t know all the acronyms.
In the Device manager properties for the USB mRoX21 here is the info:
General - Manufacturer STMicroelectronics
Driver - Provider - libwdi
Driver Files - \DRIVERS\winusb.sys and WdfCoinstaller01011.dll and WinUSBCoinstaller2.dll

Good day,
its weird this issue… when you flash the firmware wich one you choose as first?
just flash again the firmware version FMUv3

Hi David, Thanks!
I figured this one out. I went into device manager and opened the USB DEVICES properties of the pixhawk driver and rolled it back to the previous driver. That took care of my connection and was a lot faster than ever. BUT I now have another issue. I went to up load the new firmware into the Taranis and do all the calibrations and my Taranis radio is locked up. It used to boot up and connect to the X8R on the pixhawk no problem. Now the Taranis only displays"OPEN TX when I power it up and then turns off. The bootloader screen will not appear when I hold the trims in and power up and the USB on the PC doesn’t recognize it when I plug in the USB cable, only the greenlight comes on indicating the its getting power from the USB cable. I have a X90D PLUS and it appeared to work some what with the X9DPlus 2019 firmware before. Any ideas

your taranis is Eu version?
Just download open tx on your pc and if you have to update your firmware use it… more stable and with that program you can do also the back up of the previous version you have.
Bootloader is really delicate to update…

I tried downloading all four versions of the bin file; the EU 1&2 and the non EU 1&2. Each one appears to be downloaded from the OpenTX Companion program. I tried rolling back the drive in device manager. Same problem for all tries after all those tries. I can also read the firmware on the Taranis with TX Companion. The file size is 512 while the firmware files I am down loading are only 375

On power up previously the Taranis screen would go through a series of warnings requiring a button to be pressed and then go into the menu screen. Now the screen shows OPEN TX for about ten seconds then powers off. Starting in boot mode with the trim buttons pressed in does the same thing.

Just download the bootloader binary file from the frsky website and flash it on your radio… i need make some test with mine.
If during the flash of the book something go wrong the bootloader is corrupted.
I will let you know asap

You are very helpful thanks!

BUT

I can’t get into the Taranis to upload the bootloader screen, it turns on but has the OPEN TX Screen for about 10 seconds then goes out. I can’t get into the bootload screen by pressing the two trims and ON.

I tried removing the SD Card.

I tried reinstalling the bootloader driver

I redownloaded the FRsky bin file

When I try to write the firmware to the Taranis is always get the same message “New firmware is not compatible with the one currently installed”

Maybe there is a way to factory reset the Taranis?

When I plug in my Taranis my Windows explorer does not see the Taranis, but I hear the typical USB CONNECTING MUSIC from Windows explorer or the SD card

This is the screen of the Taranis, it will not get out of this screen and it goes away after about 10 seconds

You can’t see it but the letters OPEN TX are there

image001.jpg

Off to KTMB to take my FAA exam.

Thanks again for your help!

rom: David via ArduPilot Discourse noreply@ardupilot.org

image001.jpg

Yes, on taranis you can have the option for a factory reset… im looking now for files so you can fix,
which firmware version you have flash?

I have a Taranis X9D PLUS 2019

image001.jpg

ok… with hall sensor sticks?

I tried watching this and no help. He doesn’t get to where I am https://www.bing.com/videos/search?q=reset+taranis+radio&docid=608034654735237426&mid=AD733946DB078BADF340AD733946DB078BADF340&view=detail&FORM=VIRE

New info - I did try holding the three finger startup routine for about ten seconds and now the OPEN TX screen stays lit with the OPEN TX words on the screen and does not power off any more. Still don’t see the USB in device manager and no windows chime when connected. If I disconnect the USB the screen goes immediately blank. Some where I read to try another USB CABLE, so I did - got the windows chime, see the bootloader in USB in device manager, still get the same error message not compatible with the one currently installed. I am going to shut everything down and start over

image001.jpg

HERE IS THE ANSWER _ REMOTE THE BIOS BATTERY AND PUIT IT BACK IN

https://www.youtube.com/watch?v=SnJ-C_XQ0l8

image001.jpg

Well false alarm - may have fixed it for him but not me. I will see if he has some other ideas

image001.jpg

Everytime you update the firmware on your taranis you have also to update the files on your sd card… without this update you will have the error.
Bootloader is really delicate to update and if something go wrong during the flash you can corrupt it… as long as bootloader work better dont flash it.
I’ve done several test with my taranis… no issues.
Try flash this binary firmware_x9d_190722.bin (420.2 KB)

this is EU version

That appears to be working stay tuned

image001.jpg

DAVID YOU ARE AMAZING THANKS - I need to charge the transmitter battery and will return to this later today or tomorrow. The firmware loaded without the incompatible warning. The transmitter powers up with the usual warnings. The bootloader launches with the three finger salute.

ON BOOTLOADER SCREEN

OTX Bootloader - 2.3.0

Open tx-x9d+12.3.0 (2a05543a)

I plug into Windows with power off and hear the usb chime - Device manager shows USB Devices with STM32 BOOTLOADER

I plug into Windows with power on and hear the usb chime - I see the taranis and memory card in windows explorer.

Nothing in memory card folders except scripts, sounds and calibrate.

In Taranis there are three files - EPROM & Firmware bin files and a Firmware text file which reads:
OpenTX Bootloader for x9d+

BOOTVER opentx-x9d±2.3.0 (2a05543a)

DATE 2019-07-22

TIME 23:49:52

req SD ver 2.3V0019

FWVERSION _opentx-x9d±2.3.0 (2a05543a)

Interesting, the Amazon page I bought it from said it was a

FrSky Taranis X9D Plus 2019 ACCST D16 /Access Telemetry Radio Open TX for FPV (Silver)

but maybe it is not a 2019?

Can you tell me what your thoughts are?

Thanks!!

image001.jpg

if you can attach me a pic of your radio i can tell you the version… your radio is with hall sensor gimbal?

The tag on the left is the cover from the back compartment

image001.jpg

This is taranis x9d plus 2019

I notice the name of the bin file you sent is different in form than the ones I was trying to write, see attached.

This is from you

Try flash this binary firmware_x9d_190722.bin (420.2 KB)

Where did you download that file from?

image001.jpg

firmware_x9d+2019_en_200617.bin (436 KB)

Servers by jDrones