Servers by jDrones

Pixhawk 2.4.8 not entering into ESC calibration mode with Copter-4.0.2

Hello All,

I am building my new drone which based on Pixhawk 2.4.8
Recently I updated its firmware to v 4.0.2.
Then I discovered that a controller cannot enter into the ESC calibration mode.
First of all, I tried a normal way – Throttle up and power up the controller twice.
Then I tried press ESC calibration button in the Mission Plane with following controller restarting.
I also checked the ESC_CALIBRATION parameter. It was setup to 3 after button pressing.
I also tried setup it manually.

In any case the controller did not enter into calibration mode.
There was no a specific sound. The controller starts in normal mode every time.

I also checked ESC control lines by an oscilloscope (I have simple PWM ESC).
As I imagine in the calibration mode the flight controller has to translate throttle value directly to ESC control outputs. But I was observing only PWM corresponding minimum throttle level independently of
the throttle level.

I did not forget to press safety button.

I don’t understand either I am doing something wrong or this is a firmware bug.

Good day, before esc calibration, do you have done the remote controller calibration?
Just check the correct wire of your esc to the fc…

What means the remote controller calibration?
It is only about the flight controller.
As I imagine it should switch to the ESC calibration mode independently.
Even without any wires.

Have you worked through all the pages in the Wiki here
regarding setting up and calibration?

@Dave84 is referring to the Radio calibration process described here.

One thing we changed in Copter-4.0.x vs 3.6.x is we default the ESC_CAL parameter to 0 which disables the high-throttle method of starting the ESC calibration. To re-enable high-throttle method set ESC_CAL = 1.

Yes, the radio calibration was performed.

Ok. Useful note. I will investigate this.

Servers by jDrones