Pixhawk 2.4.8 Main LED Not Blinking


Pixhawk main LED was working fine a few days ago. Pixhawk will not connect to Mission Planner or APM, but the COM port shows up in Device Manager.

PWR = solid green
B/E = solid orange

PWR = solid green
B/E = solid orange
ACT = blinking blue

You have given very little detail about your setup.
Do you have any I2C devices plugged in?
A .bin file from the FC is expected when you ask support questions.
A pic of your setup would also help.
If you want information you need to supply information.

@mboland I do not have anything plugged into the Pixhawk. I would love to upload a .BIN file but I cannot connect to the Pixhawk.

I believe he has given more than enough information needed to troubleshoot.

One of the community codes for posting/replying on this forum is “Be kind to your fellow community members”, something you aren’t practicing right now.

@xistrik A .bin file from the FC is expected when you ask support questions/please attach a picture of your setup. You need to supply more information.

My apologies for being a bit short in my response.
@pixhackdad you are right, too little coffee too early in the morning.

Have you uploaded any firmware since it was working?
It may be a corruption.
What FW version are you running?
The device is live, obviously, due to the com port, but the FW is not communicating by the sound of it.
Have you tried a reflash of the FW from MP or APM2?
At least that will tell you if they can identify the board.

The LED meanings are a bit hard to find but here they are:


I would try holding down the safety switch while powering up the Pixhawk to force a reload of the I/O firmware:


Also it seems that the SD card can affect the boot up so try re-seating it or booting without it.


We are running ArduRover V3.4.1
We tried reflashing the FW, but this message pops up: "No need to upload. already on the board"
If we try uploading a different FW (e.g. ArduPlane V3.8.5), we get this message: “ERROR: Firmware not suitable for this board”


Update: We tried uploading APM: Copter V3.5.7 heli. It was successful and now the main LED blinks.
After, we uploaded ArduRover again and the main LED blinks.
We are confused, but now it works.

1 Like

Hi everyone. I am having the same issue. First time using the pixhawk, did the initial setup wizard, main led was working ok but as soon as I finished the setup and plugged in battery for voltage settings the main LED is no longer working. Tried flashing to Ardu Rover and going back to Ardupilot, still not working. ANy ideas if it is an issue with the latest firmware?